Completely Novice

Hello,

I purchased this because it seemed as though it could save me time on certain projects and still does. My problem is 2 fold.

First, I have never worked with a CNC before. Always used handsaws, routers and other traditional tools

Secondly, I am not tech savvy. I have never dont anything on a computer outside of download a program and run it.

I am having problem with Homebrew I think. I have typed it in the command but then it asks for password and does not let me download the following:
Step 2: Install Kivy Dependancies

Install Kivy dependencies by running the command brew install sdl2 sdl2_image sdl2_ttf sdl2_mixer gstreamer from the command prompt

Step 3: Install Cython

Install Cython with the command pip install -I Cython==0.23

Step 4: Install Kivy

Install Kivy with the command USE_OSX_FRAMEWORKS=0 pip install kivy

Step 5: Install PySerial

Install PySerial with the command pip install pyserial

What am I missing? I am on a macbook.

Thanks

-bash: brew: command not found

This is what I get when I try to install the other files via terminal

@robrynola I assume you’re using MacOS. brew is a ‘package manager’ (an application for managing other application installs, similar to how the Apple AppStore.app works) and its instructions can be found here: https://brew.sh

as such it requires the administrator password when run in order to write to disk and ‘do things’.

Once you have it up and running start at Step 2 again.

Basically, you’re installing the (brew) package manager, then use it to install some apps that Kivy needs in order to run.

Kivy is like a wrapper for Python, which is a programming language, Kivy allows python apps, which normally don’t have any visual elements or GUI to run in a window, display things, and have buttons and other user interactive elements, like any app you’re used to in osx. GroundControl uses Kivy to display and control maslowCNC but in turn is really using all these different ‘sub-surface’ tools to do that.

The other steps are 'libraries’to Python (like a plug-in that extends Python’s functionalty) In this case: Cython allows interpretation of the computer programming language C (and C++) and PySerial adds serial commands used to communicate via USB with the MaslowCNC audrino board.

good luck!

1 Like

Thanks for the response. When I put the home brew code in it does ask for password but for some reason it wont let me type it in, in the terminal. Is homebrew its own program that i need to run or am I putting the password in on the terminal then simply downloading the other programs through the same terminal? Sorry. Again, this is the first time I have ever accessed terminal owning a mac.

1 Like

So after research i have found out that the password keys will not show but they are still being typed. I think I may have fixed it. Sorry. First time for everything. May have more needs but appreciate the quick response!

2 Likes

yes, brew is its own program. per http://brew.sh you install it by using the command:

/usr/bin/ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”

(cut and paste that whole thing exactly.)

you can read it by understanding that it’s calling a program ‘ruby’ in the /usr/bin/ folder. it’s telling ruby that it wants to access an external command ‘-e’ called ‘curl’, which has its own arguments and a url which it will download and run.

the password allows it to do these things and write the result to disk.

2 things:

  1. your user account needs to be an administrator account (if you’re a single user on the machine it will be by default.
  2. terminal will not display anything when inputting a password, simply type it correctly and hit return.

the program should run for some amount of time (that it takes to download and install brew) and return you to an active command line.

where you then begin at step 2 from your post above:

which could be made clearer by saying:

After brew is installed type:
brew install sdl2 sdl2_image sdl2_ttf sdl2_mixer gstreamer

which you can read as: (use the program) brew (to) install (a bunch of things, and each space is a different thing in a list)

no worries, decades of work was done to make sure most computer users never have to do this kinda stuff. .

good luck.

If you aren’t interested in modifying the software you shouldn’t need to run it from the source at all and you shouldn’t need Homebrew.

Have you tried the "How to run the prepackaged version of Ground Control " instructions available here?

You should only need to do steps 1-3 on that page

1 Like