Delay in opening action screen

When I hit the action button, there is a delay in popping up the screen. I assume others are experiencing the same thing. There looks to be a lot of setup routines being run but is there one in particular that takes a lot of time? When I’ve tried to do some development work on my laptop with it not connected to the controller, I’ve noticed that sometimes the delay is a few seconds, but other times it’s well over 30 seconds. It’s odd that sometimes its slow and sometimes its reallllly slow. Is it trying to connect to the controller and pull data?

What OS are you on on the laptop? What is the processor and memory please? Make and model would help but not required.

Thank you

Lenovo Yoga 910 (Core i7 w/16 GB RAM) running Windows 10… so this is unique to me? wow… in the immortal words of Buddy the Elf… “That’s shocking!”

I didn’t notice it last night on my Lenovo T420. Let me go get it and check it again.

Thank you

It’s been happening since day one…

Off topic <<
Is there anyway to add something to our posts like a signature line? It might be nice to be able to have information like our OS, the GC and Firmware being used, Triangular or Quad, etc listed right below our name in our post, or as a signature, so that the information is always included and easily updated.

I added the info to the ‘About Me’ under Profile and if you click on my icon, it will show there. Nice suggestion. And you get the autobiographer badge for doing so… a plus

Good idea. Is there any way for it to display with posts? If not, having it pop up like you’ve done it is about as good

I’m working on a million things. However i’ve been thinking of hosting this on a volunteer database, for me knowing your location is huge, when a problem arrises I can possibly help if your close enough or maybe ask someone in the group or point you to a resource.

and yes setup specifics is part of this


Workstation type

Workstation OS

Maslow XY or XYZ


It is possible to add this to the profile in your description. But everyone has to choose to do this. I was looking into setting up a database on a hosted system and reusing our logins via API to seamlessly link the data.

Madgrizzle - you are my hero :slight_smile:

Thank you

@keith, Not that I saw. I guuueessss you could QR code it into your profile picture :slight_smile:

Nice :slight_smile:

Yeah, that’s why I was thinking that if we could have signatures with every post then people would catch on and follow suit. I suppose we could key people into putting the information into their profile, but it seems like that would take much longer to get the word out


That would be mine :rofl:

Took me a minute to figure out that it wasn’t a website :confused:

I tried to decode it and it apparently shortened the info. oh well, was fun anyway. back to our regularly scheduled programming

1 Like

OK - there is no delay on my T420. When did you last update Windows? I got a major update last night.

Thank you

This has happened since day one of using the Maslow. Months now. I just assumed it was normal. I’ll have to try to dig through and find out where it’s getting hung up. It’s only under actions that’s causing the issue. All other popups work quickly.

I know nothing of what is under the covers, I suspect Kivy and your display drivers somehow.

Thank you

It’s something to do with the ports. I commented out the self.connectmenu.updatePorts() line that gets called everytime you press actions and it popped-up right away.

When it tries to check my COM3 (a bluetooth serial port) it hangs up for a bit. And when I’m connected my bluetooth headphones to my laptop, it starts to take 30+ seconds (not always though).


That is Excellent work. I wish we could just reply “excellent” but the reply must be longer.

Well that makes sense, because it’s allowing time for the Bluetooth to handshake. Put it back and disable the bluetooth to see if it goes faster. The T420 has no native bluetooth.

Thank you

1 Like

Yeah, disabling bluetooth stops the pause. However, I don’t really want to disable it because I use it (for music). It seems for Windows, GC attempts to open all com ports (1 through 256) and the ones that don’t result in an exception, it adds to the list. Pyserial includes a routine to enumerate comports and I’m not sure why this isn’t used.