Maslow Home Maslow Community Garden Newsletter

Ground Control D-Bus startup error


#1

Gradually getting toi the point of Ground COntrol running (upgraded Linux to Ubuntu 18…etc), but now have encountered the following issue:
[INFO ] [Logger ] Record log in /home/jules-tb/.kivy/logs/kivy_19-03-16_2.txt

  • [INFO ] [Kivy ] v1.9.1*

  • [INFO ] [Python ] v2.7.15rc1 (default, Nov 12 2018, 14:31:15) *

  • [GCC 7.3.0]*

  • [INFO ] [Factory ] 179 symbols loaded*

  • [INFO ] [Image ] Providers: img_tex, img_dds, img_gif, img_sdl2, img_pil (img_ffpyplayer ignored)*

  • [INFO ] [OSC ] using for socket*

  • [INFO ] [Window ] Provider: sdl2([‘window_egl_rpi’] ignored)*

  • dbus[2846]: arguments to dbus_message_new_method_call() were incorrect, assertion “path != NULL” failed in file …/…/…/dbus/dbus-message.c line 1362.*

  • This is normally a bug in some application using the D-Bus library.*

  •  D-Bus not built with -rdynamic so unable to print a backtrace*
    
  • Aborted (core dumped)*

Any suggestions?


#2

First time i see this running 2 flavours of linux.
Is ‘pip’ installed and if so, what is the respond to -> pip list in a terminal?

Edit: My guess is that some dependencies of python/kivy are not meet.


#3

Thanks Gero pip list returns the following:
jules-tb@julestb-CF-19CHD02TT:~/Documents/GroundControl-master$ pip list
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
asn1crypto (0.24.0)
attrs (17.4.0)
Automat (0.6.0)
beautifulsoup4 (4.6.0)
blinker (1.4)
certifi (2018.1.18)
chardet (3.0.4)
click (6.7)
colorama (0.3.7)
command-not-found (0.3)
constantly (15.1.0)
cryptography (2.1.4)
debtags (2.0)
defer (1.0.6)
dirspec (13.10)
duplicity (0.7.17)
enum34 (1.1.6)
fasteners (0.12.0)
html5lib (0.999999999)
httplib2 (0.9.2)
hyperlink (17.3.1)
idna (2.6)
incremental (16.10.1)
ipaddress (1.0.17)
keyring (10.6.0)
keyrings.alt (3.0)
Kivy (1.9.1)
lockfile (0.12.2)
lxml (4.2.1)
monotonic (1.0)
ndg-httpsclient (0.4.4)
numpy (1.13.3)
oauthlib (2.0.6)
olefile (0.45.1)
oneconf (0.3.9)
PAM (0.4.2)
pexpect (4.2.1)
Pillow (5.1.0)
pip (9.0.1)
piston-mini-client (0.7.5)
pyasn1 (0.4.2)
pyasn1-modules (0.2.1)
pycairo (1.16.2)
pycrypto (2.6.1)
pycups (1.9.73)
pycurl (7.43.0.1)
pygame (1.9.1release)
pygobject (3.26.1)
PyJWT (1.5.3)
pyOpenSSL (17.5.0)
pyserial (3.4)
pysmbc (1.0.15.6)
python-apt (1.6.3+ubuntu1)
python-debian (0.1.32)
pyxdg (0.25)
reportlab (3.4.0)
requests (2.18.4)
SecretStorage (2.3.1)
service-identity (16.0.0)
setuptools (39.0.1)
six (1.11.0)
software-center-aptd-plugins (0.0.0)
Twisted (17.9.0)
ubuntuone-client-data (14.4)
unity-lens-photos (1.0)
urllib3 (1.22)
webencodings (0.5)
wheel (0.30.0)
zope.interface (4.3.2)


#4

Thank you, what i wanted to check was

My stystem:
Kivy 1.10.1
Kivy-Garden 0.1.4
Pillow 5.1.0
pip 10.0.1
pygame 1.9.3
PyOpenGL 3.1.0
pyserial 3.3

Fishing in the dark here but is xclip/xsel installed. There error message was different on this, so this is likely misleading :frowning:


#5

Is this on a Rpi?


#6

No, an intel mobile (old Panasonic Toughbook)


#7

(Centrino duo to be a bit more accurate)


#8

[INFO ] [Logger ] Record log in /home/whoareyou4/.kivy/logs/kivy_19-03-16_3.txt
[INFO ] [Kivy ] v1.10.1
[INFO ] [Python ] v2.7.15rc1 (default, Nov 12 2018, 14:31:15)
[GCC 7.3.0]
[INFO ] [Factory ] 194 symbols loaded
[INFO ] [Image ] Providers: img_tex, img_dds, img_sdl2, img_pil, img_gif (img_ffpyplayer ignored)
[INFO ] [Window ] Provider: sdl2([‘window_egl_rpi’] ignored)
[INFO ] [GL ] Using the “OpenGL” graphics system
[INFO ] [GL ] Backend used
[INFO ] [GL ] OpenGL version <3.1 Mesa 18.2.2>
[INFO ] [GL ] OpenGL vendor <X.Org>
[INFO ] [GL ] OpenGL renderer <AMD REDWOOD (DRM 2.50.0 / 4.15.0-46-generic, LLVM 7.0.0)>
[INFO ] [GL ] OpenGL parsed version: 3, 1
[INFO ] [GL ] Shading version <1.40>
[INFO ] [GL ] Texture max size <16384>
[INFO ] [GL ] Texture max units <16>
[INFO ] [Window ] auto add sdl2 input provider
[INFO ] [Window ] virtual keyboard not allowed, single mode, not docked
[INFO ] [Text ] Provider: sdl2
[INFO ] [Base ] Start application main loop
[INFO ] [GL ] NPOT texture support is available
[INFO ] [GL ] Unpack subimage support is available

This is my terminal output starting GC. The [INFO ] [Window ] Provider: sdl2([‘window_egl_rpi’] ignored) is the same, so was barking up the wrong tree. Any difference with your terminal that could give a lead?


#9

It looks like you are using an older version of kivy that is from the Ubuntu repository.

Maybe try updating Kivy to the latest stable branch.

https://kivy.org/doc/stable/installation/installation-linux.html


#10

updated kivy, but still get the same issue…


#11

xclip/xsel are installed, but I notice that some of the others (PyOpenGL, Kivy-Garden) aren;t installed and others have previous version numbers.


#12

Not much to be found:

cross-referencing each other without a final solution.

If i was in this corner, as a novice i would try in order:

  • dist-upgrade
  • removing and purging python and kivy and bringing them back by hand
  • if the 2 above do not work, bite in the sour apple and go for a different distro.

I’ve had run GC on kubuntu and lubuntu in the past and are now running it on ubuntu mate 18.04.2 LTS in the home office with Fake_Servo for debugging and Manjaro (Archlinux) in the workshop.


#13

try entering this on the command line first, then running ground control:

export KIVY_GL_BACKEND=gl

(this is a workaround for a known bug where angle sdl doesn’t work properly in the i386 version of kivy on ubuntu 18.0.4


#14

Thanks Jatt, still falls over at line 1362 unforetunately


#15

I have Ground Control running on two laptops. One running Ubuntu 16.04 LTS and the other running the newer Ubuntu 18.04 LTS.

I think In both cases getting Kivy and GC setup was just a matter of adding the Kivy PPA to my repository list and installing it with a few apt-get commands. See my bash_history below…

sudo apt install software-properties-common
sudo add-apt-repository ppa:kivy-team/kivy
sudo apt-get update
sudo apt-get install python-kivy
sudo apt install python-pip
pip install pyserial

Are you running X11 desktop with gnome? I think some people reported issues with Ubuntu 17 when it defaulted to use wayland instead of X11. Only other think I can think of is you can can break things in python when adding modules with apt and pip together. Maybe its best to just pip for adding python modules, other than adding the kivy ppa.


#16

Hi Jamtek,
Thanks for that - I’ve reinstalled Ubuntu 18.04 .2 LTS, resintalled KIvy & Python and it’s now up and running.
Jules