Maslow Home Maslow Community Garden Newsletter

Ground Control Installation Issues Communication Port

Completely new to all of this. Just put everything together on my work table to test software. Have my 3 motors plugged in to Arduino Mega 2560 R3, loaded Arduino software, got blink to work on my Windows 10 PC, USB port 5. Turned off my Norton Firewall, and get the following error on Ground Control. (from error log)
Connected on port COM5
Connection Timed Out
It is possible that the serial port selected is not the one used by the Maslow’s Arduino,
or that the firmware is not loaded on the Arduino.
Connected on port COM5
Connection Timed Out… you get the idea.

I am using port 5 both Arduino and Ground Control.

I’ve spent the entire day (9 hours) trying uninstalling, reinstalling, and even bought a new windows computer, getting the same error. I read where someone else was having same problem, I change communications rate in Arduino software, but in the window, I’m not seeing the numbers (data) communicating back to the board (if I understood that correctly)

For ground control, I used windows 7 install, and the third option, Windows app- no change in results. Can someone please help me?

I know how frustrating things like this can be.

My advice: forget GC for now, install the Arduino IDE and follow their driver/settings recommendation. Once that’s good, you’ll be fine :slight_smile:

Side-note, I find the drivers installed as part of setting up the Arduino IDE to provide the most solid connection.

There is a TON of stuff online and on the Arduino site to support you in doing this.

You do need to install the firmware. If you installed blink, you have wiped out any firmware that was loaded. Once you get the firmware installed, you should close the arduino ide because it can interfere and cause what you see.

1 Like

Thanks- sort of skipped a step!

Thanks- sort of skipped a step! sorry about that