Maslow Home Maslow Community Garden Newsletter

Pi to WebControl to Holey for complete newbs

Also, is the top right indicator (re: the image in my previous post above) red with words “Fake Servo On”?

The area on WebMPC that reads out commands and status messages?

Oh, you’re running the docker-based version from the pre-built image?

Yes. Is there a better way?

Maslopi lite I believe.

Yeah… I’ve basically stopped work on that version when I ran into issues with adding new capability. I’ve moved to a new system that uses pyinstaller compiled releases.

How much of a guinea pig are you willing to be? I’ve created something that I think (does for me) creates an image for the rpi using the new release method, but as far as I know, no one has tried it. You would be a perfect candidate to try it out if you are willing.

I created a new topic with instructions on how to use PiBakery to make the image:

100% willing to try it and report back my findings. Thanks for the write-up, I’ll start on it this afternoon.

I have it installed and running near my PC with display and mouse/keyboard going. I see there’s a webcontrol folder here. What do I do next?

In my total newbness, I went into the webcontrol folder and found the executable and ran it. Webcontrol comes up as normal.

So, now, do I use the Rpi in place of the windows tablet I was running before and webcontrol just stands in for ground control? Does this eliminate remote access?

Well, I was hoping it would run automatically from start and you not having to manually start it.

Webcontrol is accessed via a browser and replaces Ground Control. That browser
can be a mobile device like your tablet (which can be completely wireless)

David Lang

1 Like

I had webcontrol working great from my PC to my garage on MalowPi lite but couldn’t get the holey calibration to run. Grizzle is helping me in private message so we should have some progress later today.

Following this too. I have my Maslow set up with a pi and webcontrol. Tested my motors with the stock firmware (worked), then updated to holey and the motors didn’t respond. Webcontrol just have me a fail message when it sent commands to the motors. I went back to stock and they responded just fine and I proceeded to calibrate.

Outside of updating to holey in the actions menu, is there anything else I needed to do?

This is the result of asking this question. I was hoping to add pictures but I may not get around to it now that my maslow is up and running and nearly calibrated using holey. Big thanks to @madgrizzle for the private help and editing the body of the post.

Raspberry Pi and WebControl setup for complete beginners.

Be forewarned: I added a bit of stuff that’s VERY rudimentary such as finding IP addresses. Skip as needed.

1 Like

@garisonr I had trouble getting holey to work until MadGrizzle helped me. I had the same experience where I used the old installed (included webMPC) and holey just wouldn’t cooperate. The pi bakery and XML recipe method works well. After hitting “update to holey”, webcontrol will reset and re-connect and then should work fine.

1 Like

Is there a big red ‘button’ in top right with the words “Fake Servo” in it?

I had a similar problem and found that fake servo had somehow gotten enabled, I
believe that current versions show this in the status at the top.

Yep. Need to disable it?

Yes. Click that ‘button’.