Problem with first z-axis depth

Hi, hope someone can help. I have ordered from eastbaysource the kit an want to start a testcut but the first depth of the z-axis is to hight (5mm). Where can I change the steps of the depth for the z-axis?

Note: I have mount a T8 pitch screw and set the z-axis pitch to 8 at setting. The calibration looks ok. When I raise the z-axis 1mm it goes up 1mm but when I start the testcut it goes more than 5mm in depth of the z-axis

Just a guess but you probably need to alter the number of steps to meet the pitch of your screw.

Thank you

the setting is in ground control software, advanced settings.
I think you have to click on the very top row to get to it.
the default is 3.17mm, change it to 8mm. please post photo of how you changed it to 8mm lead screw.

Hi, I have already set it to 8mm. The calibration of the z axis is also working but when the gcode starts the router bit gets to deep into the material.