Maslow Home Maslow Community Garden Newsletter

Another Z-Axis topic!

Hey all! hope the machining has been going awesome!
We’ve had our machine for a good while now, we did the cheap z-axis fix, and rode it till we could.
We now have the metal maslow sled, dedicated z-axis, and upgraded motor installed.
At first try, it went comically fast and far…
we’ve managed to change encoder settings to regulate the speed, however we are at a TOTAL loss when it comes to pitch…
We’ve read over thread after thread about people and how they’ve mathed out the pitch and all that.
so far if we tell it go up a mm it’ll go up about half an inch, or further.
The cable it came with did have one of the cables that attaches to the plastic bit completely out, so we just nudged it back into it’s socket and didn’t think about it. Some threads do mention cable issues affecting the z-axis. (we’re thinking of splicing it with the old cable if that’s the problem)

Any and all help is greatly appreciated, I’ll be ready to reply to any questions about the setup to get to the root of the problem. Currently running webcontrol, holey calibration on an rp4 with wired ethernet, weighted simple system, and orange rigid router.

The encoder settings and steps need to be correct, but if you have all that, the pitch should be based on the thread pitch of the lead screw and your belt pully ratio. The lead screw is 8. The belt flips it to a negative. It would be positive if it were a direct drive. If you have a 3:1 gear down (bigger 60 tooth gear on the motor). If you have a 1:2 gear ratio (wider belt and bigger gear on the router, not the motor) it will be something else. What does your belt setup look like?
this is a 3:1


This is a 1:2

I’ve got this set up going on right now, i’ll have to check the rest of what you mentioned here soon and post back, it’s appreciated!

pitch is -24, but the encoder numbers for steps per rev are different.

hm well we did try -24, and curiously it went backwards, so 24 goes the right way, just depths that not accurate. will definitely try again

so which one controls the depth to make it accurate?

the +/- of the motor can also be flipped with a wire cross, so no worries if the sign is backwards.

I would need to go through the math to justify this one, but I can’t right now. Here is another post linked from the one above I mentioned that has different numbers you can put in to get it to work.

In theory, there is an encoder that has so many pulses per step and steps per revolution of the motor that gets counted as the motor turns. This is tracked by the controller. the motor has a gearbox with so many revolutions of the pulley per revolution of the motor. With so many revolutions of the motor, you get so many revolutions of the lead screw and with every revolution of the screw you get x number of mm of travel. the pitch is supposed to be for just the part from the output pulley to the mm distance. Try the numbers given in the link above and see if it works for you. You can adjust the pitch up or down depending on how far you are from reality. I used a caliper and ran the axis up and down several times. Report back if your numbers are different.

1 Like

I set my pitch to 24 (-24 was also reverse). Using a metal rule, without changing the default steps/rev I got my Metal Maslow to within .25mm IN ONE DIRECTION. There is too much slop in the system to have it be totally accurate up and down. Go for the down, since it is what controls the cut.

2 Likes

Ok, i’ve read through most of this stuff and am getting a better idea, i’ll do the changes and report back.

.25 is very good, i’d just want a good up and down enough to get a good safety height for longer cuts as long as it’s not retracting too much and going down not far enough…

Thanks again and will report back

Still reading this and other threads, good to know the metal maslow wasn’t just a puzzle of us here.

we did a quick measure, the first one it went down 1mm when told, then it would go down 5mm per every 1mm told…

we don’t know what to make of it as much but will continue working on it.

edit: we seem to be 3 off, but haven’t changed much, upon further measuring, when told to go down 5, it goes down 15, and when told 1, goes down 3…

I’ve encountered the same issue as you. This should point you in the right direction.

Hey thanks! we actually got it working to a very satisfactory degree, but probably couldn’t guide anyone else in how we did so. A combination of everyone elses work and dumb luck, all help was very much appreciated!

1 Like

can you post your settings?