Maslow Home Maslow Community Garden Newsletter

ModuleNotFoundError Can't install

upper right corner… does it look like this?


or like this?

It’s a combination of both. I remeasured and checked everything in the quick configuration, and at one time, the chain length message was gone, but it is back again.

that isn’t webcontrol. That is your arduino controller getting confused. This happens when power is lost during movement or if using a laptop. It happened to me when my laptop went to sleep while the cut was progressing. Is there anything else going on that we aren’t considering that could cause power failure that you have observed? On a different thread, someone was describing that their shield was disconnecting from the arduino and it kept causing issues with one of the motor movements, so they were going to ziptie the two boards together. That may not be the issue here. Anything else?

My connections are secure with power and my shield and my cables are all plugged in correctly. I just noticed now that I get the error in terminal (running ./webcontrol):

One Error Report Command Misread

this repeats infinitely. here is the full text:

./webcontrol
Initializing Logger
/home/awesome/.WebControl/log.txt
/home/awesome/webcontrol
Initializing Configuration
Camera initialized

Also, when I first open up webcontrol, and press a direction from the controls, it makes a noise, then stops, then none of the buttons do anything, no noises, no motion.

I can look at the logs and webcontrol.json file… download the diagnostics file from the Actions menu and send to madgrizzlemaslow at gmail dot com.

I also noticed a g40 command on the screenshot… maslow doesn’t support it.

The issue is that the chain lengths need to be set correctly. The last error message is :

Unable to find valid machine position for chain lengths 384.42, 123.63 . Please set the chains to a known length (Actions -> Set Chain Lengths)

The controller thinks the left chain is extended 384.42 mm and the right chain 123.63. This is too short to actually connect to the sled and therefore it can’t figure out where the sled is.

Go to Actions->Set Sprockets and Chains if you hadn’t done it once before and marked the chain link sitting on the top tooth after they were extended… if you had, then just use Actions->Set Chains. I think that will fix the error messages.

I also recommend you update the firmware to Holey Calibration firmware… I think it works better than the stock… Actions->Upgrade Holey…

As for the G40 command, what CAM program are you using to create your gcode?

The only gcode I sent was the triangular calibration and the files in the “gcode for testing” that come with ground control.

I upgraded to holey, redid the chain length configuration, tried to run holey configuration and it stopped and gave me the chain length error again. 5.6, 5.67. Terminal read stalls at sending: G00, Y25.4. Dpad Controls also still not working.

I think you might not be extending the chains correctly. You need to set both sprockets so that one tooth is as vertical as you can possibly get it. Install the first link of the chain on the top tooth and then press ‘extend chain’. It will feed out 1651mm of chain. Repeat for other side. Once done, connect the sled to the chains.

Chain likes to wrap around the sprocket, so grab hold of it and give it some tension by hand so it doesn’t get wrapped up.

That was totally it. I was clicking define zero after it measured out the chain thinking it was like 0,0 on a coordinate plane. THANK YOU SO MUCH for your advice and patience. You folks are amazing.

1 Like