Ground control issues


Im getting this error message when i try to install and run ground control. It sounds like my graphics drivers aren’t up to date. However, as far as i can tell, they seem to be updated as far as i can. Does it seem like i need to buy a new graphics card or something? I hope not. Any insight is appreciated.

That’s what I ended up doing. I looked at my existing graphics card and it said I had an up to date version of Open GL, but it still would not work for me. I ended up buying a $40 graphics card off of Amazon and it fixed the issue.


open powershell as an administrator, and run this:
[Environment]::SetEnvironmentVariable(“KIVY_GL_BACKEND”, “angle_sdl2”, “User”)

Otherwise, if for some reason you wanted to do it manually instead of using powershell, do this:

  1. right click on This PC then open Properties .
  2. go to Advanced system settings .
  3. click on Environment Variables .
  4. click on New in User variables for — .
  5. put KIVY_GL_BACKEND in Variable name .
  6. put angle_sdl2 in Variable value .