Strong Vibration from one motor

I just got my Maslow kit and am in the process of putting it together however when setting up the electronics I noticed one of the stepper motors has a strong vibration where the other is smooth and silent. Is this a malfunctioning motor?

I even tried unplugging the cable and switching connector cables but still does the same thing. I just want to make sure I don’t have a bad motor that will go out quickly.

That does not sound good.
Swapping the cables and still the same motor, is pointing to the motor.
I would send @hannah an email to get a new one on the way fast.
Some friends here have taken the gearbox apart to count the teeth. Will try to find the pictures in case you need something to do while you are waiting for the new motor :wink:

Couple of questions that don’t make sense any more after reading the description:

  • Did you try ->Test motors/encoders in GC?
  • What firmware and GroundControl version are you using and have you tested if the noise is the same with 1 or 2 versions back?
  • Did you play with settings in GrounControl?


1 Like

I think that actually sound pretty normal. A number of folks have noticed that the left motor seems to be a lot twitchier than the right one, but we’re not sure exactly why right now.

It’s generally only observable when there is no weight on the motor, right? The motor is really expecting to see the weight of the router resisting it so it will overcompensate and be jerky when the router is not attached


Has this been reported with ->test motors/encoders?

You don’t see it during test motors/encoders because the PID controller is disabled during that test. You mostly see it when the motor is trying to hold a position, but because there is no weight resisting it it will overshoot and then correct making it twitch


So that’s the next test. :slight_smile: If the sound is there too we have excluded the software. If it is silent the motor is fine.


Would that not switch by swapping the cables? :thinking:

I had reached out to bar about this many months back but the new firmware has all but eliminated this issue for me. It was always just the left motor.

@Gero I agree with you about why it wouldn’t switch unless only the cable was switched. Perhaps the OP can clarify their statement about swapping the connector cables.

even tried unplugging the cable and switching connector cables.

Did they leave the cables plugged into the driver board and simply swap the left motor onto the right cable, and the right motor onto the left cable (I assume that is the case) or did they simply swap the cables themselves out?

My suggestion is to run test motors/encoders without chains or sled attached and report back if there is still a significant noise difference. Perhaps a video can help.
If you change the cables on 1 side only (either on the motor shield or the motors), noise from software accruing at the left motor should switch and now appear on the right motor. At least I think that.


I Think so too. Which ever motor is connect to the connector MP1 would be the noisy one.


I did change the cables and it does seem to only do it on the left connection. Here is a quick video… I am using the latest Maslow Firmware Version v1.11
Motor Vibration

Oh wow, that does look different from what I’ve seen before.

To eliminate the possibility of a hardware issue, is it OK if we send you a new controller board? If you send your address to we’ll get one sent to you right away.

1 Like

Thank you I emailed my address.

1 Like

I had this same problem, but with both motors. Turns out the screws holding the motor to the gear housing were lose. I tightened those up and all was well. Thought it was weird to have the screws so lose, but it all went away after tightening.


I"ve had the same thing. one motor is dreadful, the other is great. but when i run in test mode, they are both smooth. i’ve switched cables, and switched motors, it stays with port 3 on my setup. i’ve calibrated, etc. still does the same. very rough, not useable like it is.

i’ve posted mine in another thead.