Issues with Right motor control

Received my kit a few weeks back, but due to work, left it sitting. I put the electronics together.

uploaded new Firmware v 1.10
downloaded Ground Control V 1.10

started by actions --> Test Motors / encoders.
both sides worked great.
very smooth, both directions

then went to the arrow keys.
set the distance to move to .5 inches

when i hit an arrow key, diag, 1 motor / encoder moves (port 1, left motor). When i move the other side, i get a jerky motor. so much so, it seems like there is something wrong.

i switched cables, it changed to the other motor/encoder.
i switched cables at the board, it switched again. always stayed with port 3(right motor).

I’ve not found a definitive answer on the forum. issues looked like they were due to older software / firmware, or mismatched.

I have a lot of experience on electonics and pid motor control, this i’m not sure about. the right motor will also sit and jitter for a bit after it stops. It will eventually stop, but takes a bit, seems to be bothered by noise from other motor/encoder control.

I don’t have a scope to check the signal on each line.


1 Like

I think that until one of the forms of calibration has been done, the arrow buttons aren’t useful. Go through the ‘chain calibraton’ step at least.

I did calibrate, no difference. after running a test nc file, the right motor was much hotter, and the right right heat sink was much hotter, it didn’t run any more distance than the left. No digital temp, just back of the finger test. Was prob 30 deg hotter. Motors were the same, one feels at room temp(about 70), the other feels like about 100 deg.

The sled is very jumpy with the right motor moving. slower was slightly better, but not enough to do motion control. you it is at a very distinct rate, based on the speed the motor is turning.

When i go back to the test button, it works great again.

That sounds worrisome. Let things cool off before going too much farther.
Thermal damage isn’t good, jumpy operation might be a sign of a heat problem. Look for something mechanical that might bind the right motor. Make sure the heat sink is well seated on the chip. Is there a z-axis as well? Make sure that isn’t bound up, the z-axis motor is driven by the same chip as the right motor.


I’ve not connected the z axis yet. I ran this one time with the sled connected, and then disconnected it and just let both chains connected to a weight. just to keep it all moving, with a load. the heat didn’t seem too much, but the difference in heat bothered me.

1 Like

I have the same issue with port 3. Have you found a solution? All three axis worked in test mode. From the main screen z axis either buzzes and does not move. Buzz comes from board. Or when clicking to raise the z axis the right motor moves.

I have had the same issues with motors attached to port 3.

Swapped motors and regardless which motor is attached to port 3 that motor vibrates.
No issues with vibration when running in test mode.
Have not connected z-axis yet. (Will try tonight)
Using latest control and firmware (Downloaded both the evening of April 24)
Windows 10 laptop.

Alright, lets figure out what is going on here. This issue keeps coming up and we never figure out what it is.

We know it’s not a hardware issue with a motor because you can swap the motors and the the issue doesn’t move with the motor.

I don’t think it’s an issue with the arduino shield because everything works normally in testing mode but I would like to send you both a new one anyway so we can do a side by side test.

It could be a software bug, but you are running the latest so if it is a software bug its something that not everyone sees.

It sounds like you are also describing different issues.

@djen How strong are the vibrations? Are we talking about small twitches or does the whole motor shake?


Are you 100% sure the buzz is coming from the board and not the motors? That doesn’t sound right

Would each of you be willing to try reseting all the settings to the defaults and then wiping your boards eeprom:

This will eliminate the possibility of an incorrect setting

In testing mode, the motors are running at 100% duty cycle - full power. I wonder if the folks seeing (hearing?) the noise have a very low feedrate in force. The motors will grumble as the PID loops try to very slowly move them.
I’ve noticed something like this when starting GC with a file that didn’t set the feed rate, or set a feed rate which made sense in ‘INCHES’ while I was in ‘MM’ mode. Not near GC right now, but isn’t the current feed rate shown on screen? Asking what that number is, and which mode is in force might add info to the investigation.


That is an excellent suggestion.

The feed rate is shown in Ground Control here:

What do you see for that number @djen and @rustygirl when the issue is happening?

1 Like

I will replicat the buzz and verify the source.
document the fed rate before wiping the eeprom
I can do this tonight and report back.
When the right motor jumps it walks across the table.
Note my system is lying on the kitchen counter with bogus calibration numbers. And I had not loaded a file, i was just playing with the up and down arrows on the screen. Total newbe here.

This weekend i hope to get the motors mounted to the frame.
Thank you for the help



I’m hopeful that it’s an issue with one of bogus calibration numbers giving you strange behavior. When those numbers are off the machine can do some strange things!


I have not mounted the motors yet. As noted above maybe it is a calibration setting, as that has not been properly done as of yet.

As for the motor vibration, the entire motor will vibrate/shake. This is continuous as long is the motor is moving. In comparison the other motor has no vibration or movement.

As for the speed question asked above, the readout is between 24-26 inches per minute or 500-700 mm per minute.

I also did the reset as you noted above and the result is the same. The motor off port 3 vibrates.

I will finish the frame, mount the motors and calibrate and see if that affects things.

1 Like

Lets keep trying things, but will y’all both send your addresses to so that I can get new shields sent your way. That way they’ll be to you by the time we’ve eliminated all the other possibilities

aren’t the two motors being fed their PWM in different ways? could that be the
source of the difference?

My experience mirrored djen’s

Speed 700 mm/s
Reset defaults and cleared eeprom and the right motor still shakes greatly compared to the left.

As for the buzz when trying to run the z axis.
It was coming from the right motor however I had not turned on the z axis function. I found the setting this evening along with a few others never before seen in York, PA.
Z axis works fine now.

Trying to calibrate chain length without an assembled machine is not a good idea.

Thank you everyone for the help



I was able to mount the motors to the frame and begin calibration.

After mounting to the frame there is not a vibration that I can see. Though the motor on the right makes a higher pitch noise and the motor on the left is a much lower pitch noise more like a grumble yet appears to move smoothly.

I ran the test using the chain to measure between motors and ran the chain lengths. Both operations went as expected.


Great news!

I’ve experienced that one motor is “twitchier” than the other and I’m not sure exactly why, but I will look into it and find out

I was able to set up the motors on the frame this weekend and saw the same results djen did. To summarize don’t get worrried if the motors act a little flaky before actually mounting and calibrating.


That is great news!

I am still looking into this because even if it isn’t giving you trouble it would still be nice to track down and I think I’m making headway.

Which PCB version are you each using? It’s probably 1.1 or 1.2b