Trouble launching ground control

I use my maslow infrequently. I hadn’t updated any software in about a year. I went through git and pulled updates on all the repositories, then tried to launch GC as I used to. Got the following error:

[INFO ] [Text ] Provider: sdl2 [ERROR ] [filechooser ] win32file module is missing [ERROR ] [filechooser ] we cant check if a file is hidden or not [CRITICAL] [App ] Unable to get a Window, abort.

Thought maybe I needed to update python/kivy or something like that. Went though these instructions:

now I get a different error:

[INFO ] [Logger ] Record log in C:\Users\Graham.kivy\logs\kivy_19-12-04_
[INFO ] [Kivy ] v1.10.1
[INFO ] [Python ] v2.7.17 (v2.7.17:c2f86d86e6, Oct 19 2019, 21:01:17) [MS
C v.1500 64 bit (AMD64)]

  • Traceback (most recent call last):*
  • File “”, line 12, in *
  • from                   import App*
  • File “C:\Python27\lib\site-packages\kivy\”, line 319, in *
  • from kivy.base import runTouchApp, stopTouchApp*
  • File “C:\Python27\lib\site-packages\kivy\”, line 26, in *
  • from kivy.clock import Clock*
  • File “C:\Python27\lib\site-packages\kivy\”, line 362, in *
  • from kivy._clock import CyClockBase, ClockEvent, FreeClockEvent, \*
  • ImportError: DLL load failed: %1 is not a valid Win32 application.*

I just want to cut something! So I said forget trying to run from source and just run the compiled GC distribution. Downloaded GroundControl-Windows.Portable.v1.26

Trying to run that fails too! The window just blips, but if I’m fast with “print screen” I catch:

Any suggestions?

update: I was using remote desktop to access the PC that runs GC. Going to the PC directly, I can launch GC from the compiled distribution without a problem. So seems to be related to windows remote desktop. Unfortunately my method for running from source seems to be broken though…

1 Like

Wow! You are really quick. Nice work catching that.

I think this is the critical line. Something is preventing Kivy from opening a window. Do you see the same error message with any of the Kivy demos? That would let us know if it is a Kivy issue or a Ground Control issue

Remote desktop can be weird with kivy. I’ve had luck using teamviewer instead.