Maslow Home Maslow Community Garden Newsletter

CAM software to begin

You’ve all been super helpful. I think my Maslow has been calibrated (hope, hope) but I cant get any software to generate GCode.
Arduino, Pycam, Inkscape and a lovely flash based web browser fail to work for various reasons.
Easel Pro appears to work but can’t “see” my machine. Also, it doesn’t appear to be very Maslow compatible. I had to keep selecting “other” on drop down menues.
I know absolutely nothing about Cam.
I have a mac running OS11.2.3 (“Big Sur”)
Can you recommend a graphics based software solution for a total noob?
Thanks

download carbide create. save the svg from inkscape and open it in carbide create. A simple example using that program are found here. Skip the trace part which uses corel draw and jump down to the carbide create portion. Then once you get your tabs set, save your gcode file as .gcode or .nc and then open it with groundcontrol, webcontrol or makerverse depending on which machine and software package you calibrated with.

Inkscape is not compatible with my computer. There are no further updates sadly

Blender? Coreldraw(not free)? Anything that can save an svg… Illustrator also not free, but that works on a mac. Then use carbide create and generate gcode. If you use easel, export the gcode, don’t try to control the maslow with it. It will not work.

OK thank you. I’ll try that.

Curious as to what errors you are seeing an issue with in Inkscape. I too use a Mac, a 2012 MacBook Pro actually. It’s an oldie I know, but is also on Big Sur os. I use Inkscape daily without issue.

If you just mean the fact that their download page doesn’t show the Big Sur is version, don’t let that bother you. It downloads and runs fine.

I use Carbide Create to generate my gcode from my svgs that I create in Inkscape. The tutorial linked above is a good resource and what I followed the first time I used it.

Easel Pro doesn’t seem to have any way to share, export, save etc. to use in Arduino or ground control.
Thanks

Which version? I have 0.92
My computer says I must update it to run but can’t find a newer version

For easel, it’s not as easy to find but here’s a link to their documentation on generating the gcode: Walkthrough Tutorial: Offline Easel Usage – Inventables

For Inkscape, I’m on version 1.0.2 which can be found here: Download Inkscape 1.0.2 | Inkscape

right I just found it. It was listed as development version.
Thanks.
Wish me luck!

Paxman - What OS is on your PC?

Thank you

OS 11.2.3 Big Sur

OK I found a simple design on Easel, exported the g-code and got a .nc file.
I tried to open it in Arduino but no luck. I also tried to drag and drop. Found no import commands.
I’m surprised I can’t seem to find anything on YouTube either.
I know you all figured it out, but I’m still lost.

@Paxman Once you have your .nc file, you will use GroundControl, WebControl, or Makerverse to read the .nc file and have your machine cut. Whatever program you were using to calibrate your machine will be what you use to cut with. In that program, there should be a menu option to Open or Upload your file. What program did you use to calibrate your machine, and what version of the Maslow do you have? That may help us get you on the right track from here.

OK thanks. I tried that but something went weird with the image size and I couldn’t get it to work. But now I know I’m on the right track
Thanks!

OK I’ve tried 3 different .nc files and none import correctly. One comes in 10x the size, one comes in as just a single line (also too big to cut) and the other doesn’t appear at all.
Any suggestions?

@Paxman I’ve never heard of this. Are you using WebControl, GroundControl, or Makerverse. I don’t mean to seem off putting, but make sure your product in Inkscape (or other program) that you are designing is to the correct scale/measurement (I am sure you are already doing this, just wanted to verify). If that is good, then your .nc file should be the appropriate scale, and you should be able to cut appropriately. I am sorry I don’t have a better answer, but I am at the end of my knowledge if everything is to scale, but your .nc file is being read as not. Hopefully someone much smarter than me can jump in here for an assist.

it’s the correct scale or at least I think it is.
I’m gonna have to hire a troubleshooter. This has become so crazy having to use 3 different programs that don’t work well together. I’m surely missing something fundamental. I know zip about graphics. I have a Mac and am totally lost.
Thanks for trying

I’m lost on a Mac as well. My wife had one, and it drove me bonkers trying to help her figure stuff out.

As far as anything else, I’m sorry this has become so crazy. I haven’t seen these issues before, so I don’t know where to even start.