Maslow Home Maslow Community Garden Newsletter

Error message during uploading Arduino

#12

After modifying the baud, I have the following:
PE: 0.00,0.00,127
MPos & WPos are all with zero value.

1 Like
#13

So you have uploaded the firmware successfully!
Check your port in the bottom right. Close the Arduino software and give a few seconds before opening GC. In GC click on -> actions and then on ->ports and choose the same port that you used to upload the firmware.
Click -> connect.
GC should now show a ‘connected’ and report like in the picture above.

2 Likes
#14

Thank you.
It is connected.
Motor is working.
But the screen has slight difference.
It is not included:
Position Loaded at
and all the numbers is Zero.

2 Likes
#15

Great news! Let us know how the calibration goes.

1 Like
#16

Everything go smoothly but the distance between motors = -12.7 mm
I have tried several times but the result is almost same.
there for the message “the correct calibration procedure for your machine in being generated”
Kindly help.

#17

Read this post completely… I suspect you aren’t doing this step correctly… don’t worry, you wouldn’t be the first:

1 Like
#18

Thank you.
What is the meaning of “hook the third link on the right motor…”.
After using “pull chain tight and measure button” the chain become tight for a second and make a sound and has some slack again, so is this normal and how can take the measurement in this case?
Measurement from which points?
Is there is a way to be sure that the machine cancel the old figures, or this not important?

#19

The picture in the bottom right corner of that message is showing the “third link” hooked to the top of the right motor. The most important thing to take away from the instructions is that you cannot manually lay the chains across between the two motors and then hit measure. You must put the chain on the left motor as shown in the left picture and then hit “extend” button repeatedly to have the left motor feed out enough chain to get it to attach to the right motor, as shown in the right picture, which then results in the machine looking like the middle picture. Only then can you press “Pull Chain Tight and Measure”.

1 Like
#20

In GroundControl what is the Rotation Radius.

#21

The distance from the centre of the cutting-bit to where the chains attach to the sled.

image

2 Likes
#22

Rotation radius is (generally speaking) the distance from the router bit to the point on the ring/linkage kit where the chain is attached.

2 Likes
#23

In GroundControl I have follow all the required steps to measure the chain several times.
Every time the distance is -12.7mm, so I have changed manually to 3030mm.
I have the following message:
(the sled is not keeping up with the expected position and has halted. Click stop button to clear the alarm. More information at https:// github.com/MaslowCNC/Firmware/wiki/keeping.up)
I have tried the Right Motor also after changing the distance to -12.7mm but still receiving the same message.
I hope nothing happened to Motors.
Kindly help.

#24

My suggestion is to first figure out why you are getting a -12.7 mm distance between motors… I really, really think that you aren’t following the steps correctly because a -12.7 mm distance makes absolutely perfect sense if you are just manually laying the chains across the sprockets rather than using the left motor to feed out the required amount of chain. Watch this video, starting around the 3:20 mark… it gets blurry from time to time, but the author is doing it correctly.

2 Likes
#25

I have follow all the mentioned steps as above and still the distance between the Motors is -12.7mm.
However I continue and during the adjusting of the left chain the motor continue to work until the string start to be close to the motor (different from the film above) so I have to stop the machine.
In addition, is the value mentioned in the film ( 3050mm) generated automatically?
Please help.

#26

I don’t understand how it gives a value of -12.7 mm. If you set the sprockets to 12 o’clock and hit define zero in the previous step, then extended the chain from left sprocket to right sprocket by the method shown in the video, when you press measure, it should give you a number close to what you measure by hand.

#27

I have follow all the mentioned steps as mentioned in DIY Homesmith Step 5 part 3 and still the distance between the Motors as mentioned in the summary is -12.7mm.
However I continue and during the adjusting of the left chain the motor continue to work until the string start to be close to the motor (different from the film above) so I have to stop the machine.
In addition, is the value mentioned in the film ( 3050mm) generated automatically? Please not that I have only the value which I entered for rectract.
Please help.

1 Like
#28

Never seen a minus in the motor distance, for now just go to settings and change to what you measure by hand. Close GC and reboot.
What is the behaviour now if you move the sled with the arrow keys in GC?
Is direction correct?
Please also upload a copy of your ->groundcontrol.ini<- here. In widows it’s found in the user folder I think. Don’t worry, we will crack this nut way before christmas :wink:

#29

[Computed Settings]
distperrot = 63.5
kpposmain = 1300
kiposmain = 0
kdposmain = 34
propweightmain = 1
kpposz = 1300
kiposz = 0
kdposz = 34
propweightz = 1
kpvmain = 5
kivmain = 0
kdvmain = 0.28
kpvz = 5
kivz = 0
kdvz = 0.28
chainoversprocketcomputed = 2
fpwmcomputed = 3
kinematicstypecomputed = 2

[Maslow Settings]
bedheight = 1219.2
openfile =
motoroffsety = 430.0
sledwidth = 310
zaxissafeheight = 5
bufferon = 0
bedwidth = 2438.4
comport = COM6
macro1_title = Macro 1
sledheight = 139
macro2 =
macro1 =
zaxis = 0
sledcg = 79
macro2_title = Macro 2
colorscheme = Light
zdistperrot = 3.17
motorspacingx = -12.7

[Advanced Settings]
rotationradius = 150.0
chainextendlength = 1650
kiv = 0
gearteeth = 10
spindleautomate = None
kdvz = 0.28
chainsagcorrection = 0
chainpitch = 6.35
chainlength = 3360
propweightz = 1
zencodersteps = 7560.0
maxfeedrate = 800
enablepospidvalues = 0
rightchaintolerance = 0
enablevpidvalues = 0
maxtouchprobeplungedistance = 0.0
kpvz = 5
kdposz = 34
chainoversprocket = Bottom
kpposz = 1300
fpwm = 490Hz
kdpos = 34
encodersteps = 8113.73
truncate = 0
homex = 0.0
homey = 0.0
kinematicstype = Triangular
kipos = 0
kdv = 0.28
kiposz = 0
digits = 4
kppos = 1300
kpv = 5
propweight = 1
positionerrorlimit = 2.0
kivz = 0
leftchaintolerance = 0

[Ground Control Settings]
zoomout = pagedown
centercanvasonresize = 0
viewscale = .45
zoomin = pageup
validextensions = .nc, .ngc, .text, .gcode

[Background Settings]
backgroundfile =
manualreg = []

1 Like
#30

With reference to the behavior, I am checking and will come to you soon.

1 Like
#31

The arrow does not make any movement.
After reboot and open the GC received this message:
(Unable to find valid machine position for chain lengths 0.00, 0.00. Please set the chains to a known length.

1 Like