Maslow Home Maslow Community Garden

Error Message that Sled is not Keeping Up


#1

Last week I noticed that my sled was not cutting smoothly, I blamed this on using Fusion 360 to make g code.

Then one day last week I got an error message that the sled was not keeping up, I just by passed and finished the project

Today I can’t cut anything with out an error message.

I saw a post about doing a encoder test, so I did one

The test failed twice, then it passed…

Do I need to order a new motor? Any help will be greatly appreciated.


#2

You didn’t mention whether the motor moved during the failed portion of the test? I’ll assume it did…

Let’s start with the easier/cheaper things - unplug/replug both ends of the motor cable for that right motor and run a series of tests.

The test runs the motors one at a time at full speed and watches the encoder pulses from that motor to see that they are present and in the proper relationship to each other. A slightly skewed plug can make one of the encoder signals slightly noisy and cause an intermittent failure for the test.

If that didn’t fix it, suspect that particular cable or motor - swap the left and right plugs at the motor control board to differentiate between a board/gpio problem and a motor/cable one. Then swap the motor ends to test the cables.

If the problem is the cable, it might be a damaged wire (orange, green, white, yellow for the encoder), something that you might be able to fix. If the problem is the encoder, you can take the cap off the end of the motor and take a look. The encoder on the stock motors is magnetic, so metal filings could cause trouble. The solder connections might be harder to check and repair, but saving $ is a thing.


#3

I just ran the test again, right motor 1 failed. The motor didn’t move, but made a clicking sound.


#4

Just swapped the cables from right to left, both motors worked and passed the test.

Then swapped the cables back, did test, both motors worked. Loaded G code and pressed play, error message popped up that sled is not keeping up


#6

What version of firmware and GC are you using? Are they he same, are they current?


#7

I am using 1.2 for both


#8

It might be useful to do an Actions/Advanced/WipeEEPROM. You’ll need to recalibrate the chains after that, but it might help.


#9

will try that.

should I do a full chain calibration or just a the quick one when i wipe the EEPROM?


#10

Not sure I understand the difference; I’m talking about the process where you set a tooth vertical and then extend the chains from their first link. First wipe the ERPROM, then Actions/SetChainLengthAutomatic.


#11

I think my USB cable maybe the problem. I moved the laptop and lost connection during calibration


#12

:upside_down_face: That came out of left field! If that fixes it, then it’s fixed - you can’t argue with success.


#13

Heat sink fell off controller. Is there a special tape to stick it back on with?

Also, I picked up a new USB cable this morning…I am really hoping this fixes the problem…


#14

There is the double sided thermal tape that was used. It’s not as conductive for heat as paste and doesn’t last as yuo’ve seen. Better an adhesive thermal paste like https://www.amazon.com/Arctic-Alumina-Thermal-Adhesive-5g/dp/B0009IQ1BU
There are cheaper options but make sure it’s adhesive or come up with a clip holding the heat-sink.


#15

I have some thermal stuff that I used between the processor and heat sink (Not sure if it’s adhesive or not) when I built a computer way back.


#16

A zip tie and you are good to go :slight_smile:

Just clean the tape off.

Edit: If there is space with the Arduino under… I did not try it, just stole from here:


#17

I replaced my original USB cable today, did with motor test and the motor failed.
I checked all connections again. I did notice my left motor connection was a little loose,but still plugged in good. I used a zip tie to make sure it would hold in place.

Motor test passed.

I loaded a gcode file and pressed play. Then I got the message “sled not keeping up”.

I checked all connections again.

I cleared the gcode files, loaded another file, then I noticed that for some reason my file was not cutting into the materiel,but rather cutting above plane. I scrapped that file and loaded an older file that had worked in the past, and this worked. Part was cut out. So I blamed my gcode file from fusion360.

I loaded a second file, new today. It made it through all the pocket and bore cuts, but when it got to the profile cut it failed again.

I did a motor test and got yet another failure.

Will attach video of motor failing

Currently running version 1.2 in firmware and ground control.

Any suggestions?


#18

Uploading: IMG_5699.MOV…


#19

Attempted to upload a video of the motor making electronic beeps etc, but the file is to large to upload here?
I am had bought a new motor cable awhile back when I cut through the z axis cable, but never used it…I had the other cable fixed by an electrical guy and its fine since…
Installed the new motor cable motors passed initial motor test, but failed when I tried to move the sled to a location.

i cleared the log file and loaded a quick gcode file for testing.
I will attach the files for review (please note, that i am still learning fusion 360 and i haven’t learned what to turn off, so there are a few lines that are ingnored)

log.txt (693.8 KB)

zplate test.nc (43.8 KB)

i really do appreciate all the help with this issue


#20

The clicking sound in post #3 suggests a possible stripped gear, the intermittentcy suggests it might be worn and not quite fully OPD


#21

I can hear a series of beeps. I don’t hear the electric motor trying to tire. Then you hear a beep and the motor turns in the opposite direction