Maslow Home Maslow Community Garden

HELP ME Maslow Wizards


#1

I need help. My system has been running and stable for a while. I just completed the Meticulous Z upgrades and all was running well until two days ago.

Not sure how to classify or summarize my problems more concise then the following.

My system was running, in the middle of a program (cutting a simple circle near the middle/right side of the sheet about 12" from top of sheet), when it just stopped moving. I received the dreaded sled not keeping up warning. I am happy I was closely watching or it could have been a fire. I shut off router and worked to raise the Z up to Zero position. I had to restart GC completely to gain control of the Z axis to be able to move the sled or get any reaction in the program. I ran the motor test and it failed in the first direction on both L & R motors (Z worked fine). I checked (disconnected and reconnected) every connection, restarted everything and upgraded to the newest latest software versions.

I checked for any thing on the cutting surface that could cause the sled to stall (Nothing). My sled has a full sheet of HDPE under it so it is as friction-less as I can make it. I re-ran the program with the vacuum turned off (I thought maybe it was “sucking” the sled to table causing it to stall) and it still failed in the same manner in the exact same physical location.

I removed the sled and my counterweights and ran the motor test again with the chains slack. All motors passed in both directions. I re-attached my sled and then moved it around the work surface in all directions and it was perfect. I decided to run a “simple” program (a circle) in the exact same location I was cutting when the first stop happened without the vacuum on.

The exact same problem happened when cutting the circle. It stopped in the exact same physical location as all other times. The motor test again showed both L & R motors fail in direction 1.

Is it possible that I have dead spots in my motors? I can not think of anything else to do, change or check. I don’t know if there i a problem with the motors, the Arduino, the Maslow card…?


Error Message that Sled is not Keeping Up
#2

I would be very surprised if there were something wrong the motors or the electronics.
Could you upload your .nc file, and maybe your log.txt (probably need to .zip that)? If the problem always occurs at the same spot, can you remember which line that was? While you were running this was the ‘Home’ at 0,0, or was it moved?


#3

please post the file you are cutting.

try moving the home to somewhere else on the sheet and ‘cut’ it without a bit in
the router

dead spots in the motors would hit you all over the place, the sprocket does a
complete rotation every 2.5 inches, so if it was a dead spot you’d hit it that
frequently.

David Lang


#4

since you can reproduce the error, clear your log file and run things until
the error happens and upload the log file.

David Lang


#5

I will re-run the simple circle program and get the clean error log tomorrow night when I can get back to my shop again.

Here is the first set of logs.
Fail motor test set 1 Log.txt (92.4 KB)

In this log, I simply started GC, moved the sled around in all directions and then performed the motor test. Failures.

The second set is just me running the simple program and it failing.

Fail motor test set 2 - Program run Log.txt (25.0 KB)

Panels and piecesZZ.nc (1.9 KB)


#6

Well, i’ve got good news and, well. I’m puzzled about the other.

The good first, the reason your ‘Panels and piecesZZ’ file fails is because of a flaw that affects G2 and G3 gcodes introduced in v1.24 of the firmware. A tested, corrected version of Firmware-v1.24:
Firmware-v1.24-Issue-476-G2-gcode-error-corrected.zip (84.9 KB)
I’ve run your file with both version of v1.24 and can confirm that the ‘…error-corrected’ version runs it without error.

The puzzling thing is in your log file, where both left and right motor failed their respective ‘Direction 1’ test. The puzzle is that both motors worked flawlessly in the tasks of driving the sled around a 1" square before the motor test was run. The test runs a motor at its top speed in each direction and looks at the encoder signal to see that the pulses are in the correct relationship to each other and that a reasonable number of pulses occur during the time the motor is running. I don’t have an explanation for why the test should have failed. I don’t think there’s any connection between the motor test failures and the problem you saw with the ‘Panels and piecesZZ’ file though.


#7

I am glad you found at least part of the problem with the firmware. It my have been a long running problem as the problem I had originally with the Gcode program failure was running version 1.12 (GC and Firmware). My system is not live on internet so updates are not done as regular as should be.

When the motor fails the test in direction 1, the motors don’t even try to turn, then just make a strange noise. I will try to get a video of one of the motor failure tests so you can hear it. Hearing and watching the test fail may provide insight.


#8

I uploaded the firmware upgrade and retested the sled. Same issues. I decided to run the motor test without the sled attached and they all passed. I reran the test again with the sled attached and it failed. I restarted GC and retested the motors again after running it around the board a bit. I lifted on the sled to reduce the weight the chains would feed during the test and could feel the drag on the motors pulling on the chains.


#9

I’m with you here,

but here I lost the thread. What was the result after restarting GC? Did reducing weight make the tests pass? What does the sled weigh?

I’m wondering about the amount of time between finishing the ‘running around’ and doing the ‘Test Motors’. Could you repeat the test, but wait maybe 30 seconds after the sled cones to rest from the last arrow-button click before doing the motor test? I’m wondering if the PID loop is still wound up. The description of motors making noise but not turning suggests some problem with the PID loop…


#10

After the restart of GC, the reduced weight did make the motor test pass. The sled is on the light side (20-22 lbs). Just a guess as we do not have a scale in our house for me to weigh it.

All of my motor tests had well over a 30 seconds pause before after sled moves.


#11

Ok, I was grasping at a straw. I thouygh I saw a shorter time in the first log file.

So, the test passes with reduced weight on the sled now, but it still fails on Direction 1 for both motors growling even after restarting GC?
Would you look to make sure that ‘AdvancedSettings/EnableCustomPositionalPIDValues’ and ‘AdvancedSettings/EnableCustomVelocityPIDValues’ are turned off?

I don’t remember whether you’ve been through the ‘Actions/Advanced/WipeEEPROM’ then restart GC and recalibrate chains sequence with V1.24 in our struggles. Recalibrating the chains is a bother, but wiping the EEPROM will make sure that the stored values are arranged in EEPROM in the manner that GCv1.24 expects. All your settings should survive intact with the exception of the position of the sled, hence the chain recal.

I remember you’ve cut a lot of things with your rig in the past, some very impressive projects. Has anything changed other than the GC and firmware versions?


#12

No changes to the software when problems began. I have not redone the chain stuff. I may do the wipe and reload today if I get enough fresh time.


#13

I reset my eeprom. Reinstalled and set chains. Moved sled around the table. I then shut down and restarted GC. I again move sled in 1" square pattern. Stopped and waited >30 seconds…ran the motor test and it failed again.


#14

This certainly is being a puzzle. Could you try this – quit ground control, start ground control again, and first thing after it announces the version of firmware and ground control that are in use, run the motor test, no other movements before the motor test. Does it pass then?


#15

Let’s widen our view - Please tell us the make and model of PC your using? What OS are you under?

Thank you


#16

Did not pass.


#17

I am not at home, but I am running a low end Dell notebook with windows 10 premium.

The computer is a Dell Inspiron 11 3000 series.


#18

If I remember right, the z axis passed in your testing. Would you swap the z cable with one of your chain motor cables and run the motor test? Does the chain motor attached to the MP2 (z) connector turn as expected during the z test, passing the z test? Does the z motor now connected to a chain motor connector stutter and fail Direction 1?
Sorry to send you so many little tasks. I’ve tried making the problem happen here, but I can’t reproduce it.


#19

The z passes all tests. Can’t swap cab els.as they are different for L & R than for the z.


#20

I was hoping you would swap the ends plugged into the PowerControl card, which are all the same. Swap the two plugs and run the ‘Test Motors’ test. I’d like to know how the z motor acts in the motor test when it is plugged into the right chain motor socket, and how the right chain motor behaves in the test when it is connected to the z socket.