Maslow Home Maslow Community Garden Newsletter

G code not working but manual adjustment does

So there I was doing my first cut. I had to keep pushing the sled against the board because the cut pieces go all the way to the bottom and top of the board. Anywho, because the process was taking so long from having to stop and start again I decided to pause and take a break for the night since I didn’t want to stand out there for hours with my finger pressed against the sled. I made sure to note the position # and coordinates of the router because I saw there was a feature to return to that portion of the g code in case you get disconnected. Well when I came back my ground control was disconnected. After reconnecting and attempting to resume the position # would move forward but the router would not move or it would move a very tiny bit that was unnoticeable. I tried disconnecting and reconnecting, closing and reopening, manually moving with the purple arrows (this worked unfortunately after I realized the step was set to 3.94), etc. Nothing is working. The cut refuses to actually resume even though it thinks it is. The motors still appear to be functional since I can manually move it.

I think this is the key to what is going on. I am guess the part is design in inches and the machine is now operating in mm. The first few lines of gcode do important things like tell the machine if the rest of the code is in inches or mm. I would try running the file from the beginning for a few seconds (you can leave the router off and lift the sled away from the wood if you don’t want to cut), then use the goto feature to go to the line where you would like to begin.

Gcode is really not meant to allow you to enter the program at an arbitrary point so it can be a little tricky.

Thanks! I’ll test that out tomorrow. It’s getting a little late now. Will let ya know how it turns out!

So definitely having all kinds of issues now. Before it was working very well. Now my z axis clicks sometimes when moving, whenever I start the g code over again I immediately get the error that says that the sled cant keep up, the z axis does not appear to be moving up when the router prepares to move occasionally, the motors all fail their tests, and the list goes on and on.

ok, we need to go back to the beginning.

power cycle everything (so that the state is reset), try doing the motor/encoder
tests.

Until they work, nothing else is worth trying.

So I unplugged the board from the power and waited for the light to go out, unplugged the board USB from the comp and restarted ground control. Still fail in all directions. There is sound from each motor during the test as well and all connections are good

Anyone able to help?

Are you still seeing all of the same issues? Give us an update on exactly what the first issue we are trying to solve is

It all started when I left it paused mid cut overnight. My computer went to sleep and when I came back to it the next day it had disconnected from the board. I tried to reconnect and resume, but that didnt work. Then I tried to restart and goto position and that didnt work. Now, after resetting (power cycling and unplugging) everything (board, program, usb) the motors all continue to fail their test even though some sound is made. Additionally, I get an error when trying to restart saying something about the sled not keeping up with the movement.

To be more direct about answering your question: yes, all of the problems still exist and I would imagine the error code about the sled not being able to keep up with the instructions would be the first issue to solve although I would assume the motors failing the tests is closely related.

What lights are on the motor controller board? Sounds like a motor controller issue (check to make sure power is plugged into the motor controller and not the arduino)

1 Like

I agree with @madgrizzle. When all the motors are failing their tests the issue is usually with the power supply. Is the 12 volt power light on the board illuminated? Is the blue light on the power supply on?

To me this doesn’t feel related to the computer going to sleep, although I could be wrong.