Maslow Home Maslow Community Garden

Cut Stopped + Won't Start at Line of G Code


#1

I’ve been cutting a large file and due to not having a lot of time to be in the same room, I started in a few days ago and would come in for a couple hours at night and resume the cut. I came today to continue the last little bit, and I believe it lost power overnight and won’t continue where it left off, even though it was positioned correctly and knew what line of G-Code it was on. I closed Ground Control out and re-open it, restarted my computer, cycled the power on the Maslow, re-set my chain lengths and nothing will let me continue on my line of G-Code I was last on. I can hear the motors make a noise after I enter the line of G-Code but they don’t move. I would love to avoid re-starting since currently I’m on line 16772 when I stopped, only about half way done. Anybody else have this issue?


Can't go to line of code
#2

Often times one line of gcode will rely on earlier lines to do things like set the speed. My guess is that an earlier line is setting the speed and so by jumping ahead the machine doesn’t know how fast to move. You can also have issues with inches/mm not being set when jumping around or in the case of cutting circles the position of the machine before the circle command is used to define the circle so jumping into a circle command can have weird effects.

My advice would be to let the program run from the beginning for 20 lines or so to get things going properly and then try to jump to a straight line (G1) command

Jumping in can be tricky, good luck!


#3

I had this problem. Tried everything that anyone would suggest. THE SOLUTION I found? the g code line that you choose must be a z axis command. @bar is right it can be tricky because I was using a couple of techniques at once and ended up slicing through my previous work as the machine “knew” where it needed to be but “ignored” the fact that it was passing through material that should’ve never been removed in ALL of the gcode. Patched and painted… all’s well that ends well. Hopefully I have managed to link you to the August subject below. Blessings on your ventures! You’re gonna get it! :man_dancing: :bow_and_arrow:


#4

unfortunantly, there is state from prior lines in the file that you need to keep
going. If you lost power, you lost that state.

it is possible to go in and edit the g-code to eliminate stuff you don’t need to
get going again, but that takes understanding the g-code and is a lot of work.

David Lang


#5

Oh yes… For sure I didn’t mean to disregard the importance of the other steps that should be taken! :grin: I just tried everything and none of it worked without the last Z-Axis command being the line of gcode to “go-to”.


#6

I ended up figuring it out. I had to skip a few Z axis movements back for some reason. I was cutting an oval outline and it almost appears that the start of the oval was the only time the speed was set. Got that working though, thanks everybody for the help!