Maslow Home Maslow Community Garden Newsletter

GCode error or bad Z-Axis

I’m trying to figure out if my z-axis motor is having issue, if there’s something wrong the g-code processing or if I just an idiot in general.

I’m trying to cut the sled from the meticulous z-axis (the file without the drill points/engraving) and it wont’ cut correctly.

So to make sure that everything is more or less functional i got the z-axis tool in GC, raise and lower it and it works pretty much exactly like I expect. Hit touch zero and done and try to run the gcode again. Same outcome (well more or less).

So I’m looking at the gcode in it and trying to see whats’s going on but I can’t get a cut to work the way that I think it should. Based on that I’ve reduced the code down to just this:

G0 G40 G90 G17
G21

G0 Z5
G0 X177.029 Y343.185
G1 Z-4.625

So, from what I understand, this should raise the bit to 5mm, move the sled (which it does) then lower z to -4.625mm into the material instead it just lowers the z to .375. The more or less comment above is because, obviously it’s relative to where the Z axis was when I start.

From what I understand that’s the expected behavior if I was using G91.

Trying to narrow down the problem it seems that the G0 Z5 doesn’t really seem to do anything much at all one way or the other and neither G1 Z0 nor G0 Z0 seem to do anything at all when processing the gcode, however if I hit stop then home it usually wont raise the bit but it does seem to honor returning it to 0,0,0.

At this point I’ve run into so many problems trying to get this thing running that I’m wondering if the motor is having a problem with the commands. Or, if I’m really that dumb, if I should just box this up and list it on ebay.

Any help would be greatly appreciated… I’m going to go drown my shame in copious quantities of a common fermented liquid before I choose to introduce this machine to the splitting maul of retribution

-Dave

2 Likes

Welcome to the Forum @drmastermind!
In GroundControl under Actions there is a Test motors/encoders. Does Z pass the test?
Upload your g-code as a file. Although the code posed looks correct. G90 is absolute and should lower to z - 4.625. Some ‘illegal’ characters in the code?
There are online cnc simulators that can be used to check the g-code.

Kind regards, Gero

you never set the feed rate in this g-code

change G0 Z5 to G0 Z5 F500

and similarly add F500 to the first G1 line

you also have an extra G0 at the beginning of the file that I don’t think should
be there.

David Lang

1 Like

thanks for the replies.

@gero I’ve done the motor tests a couple of times and they pass. I’ve run the code through one or two websites and Camotics and none of them complain about it. The only thing that did strike me as odd is that camoitics doesn’t show any of the cuts going through the back of the material in the sim even though if I watch the Z while it’s running it clearly goes 18.5mm into it.

@dlang the G0 looked odd to me but all of those were out of the meticulous sled gcode files (since I figured that they should be working code). I did try to remove it and put the F500. after the line but it didn’t make any difference.

To rule out my any of my code as a possibility I loaded the MeticulousSled_All.nc from the meticulous z-axis and ran it. I had it skip over the engraving section and go to where it drills the holes, the first 10 holes it drilled it did it just fine, the next 4 it didn’t lower the bit at all and then the last 2-3 worked. When it switched over to the router bit the first cut was fine, then next one didn’t retract so I manually picked the sled up and held it while it was moving to the next stop then put it down. It cut that hole fine and retracted but then wouldn’t go down a all for the next cut. That’s where i finally gave up and stopped it.

I don’t know if it has any bearing on anything but I do have the newest version of the shield and I have done the holey calibration. I had all kinds of problems with holey so could there be a chance that something with that is causing an issue?

-dave

solved… I should have remembered my Dilbert Tech support lessons. Unplugged, re-seated cables and rebooted everything and viola workin like I would expect it to.

2 Likes