Z axis motor problem

I have just added z axis to my cnc, but got an problem with it. In ground control where can define z axis if i press raise or lover router it works correct, but when i start my project router where it needed to lower, it raises. All cables are connectex corect. Calibration is done. What i am doing wrong? Z axis motor is connected through right spin bolt.

Welcome to the forum!

This could point to a Z0 not set at the top of the sheet, but at the bottom in your CAM. All Z moves would be in +Z. Something you can check with a txt-editor in the .nc file.
If there are no -Z, GC will not put the cutter in and cut air.
What programs are you using to create the file?

I will checkout it, but if it will be ok, maybe have other ideas? To generate gcodes i use makercam.com

Did you tell GC before the cut where Z0 is?

in GC where is button z axis, with buttons raise and lower i made the bit touch surface, and the press save and raise for traverse, and last press done.

1 Like

Did you use the minus/- in makercam for target depth?

Edit: and ‘stock surface’ 0?

yes that

1 Like

I don’t know how many likes and replies you need as a new user to be able to upload a file. Can you try to upload the cut file here. I can check if it’s the file or a machine problem.

Edit: GroundControl version and Firmware version would also help to replicate the issue.

Part of my file
(Generated by PartKam Version 0.05)

G21 G90 G40

(pocket 1)
G0 Z1
T0 M6
G0 X260.8502538071066 Y211.61395939086293
G1 Z-2 F200
G2 X274.81472081218277 Y185.06091370558377 I-143.55583756345177 J-92.44416243654823 F200
G2 X283.5913705583756 Y157.497461928934 I-152.06345177664974 J-63.60659898477158
G2 X287.11167512690355 Y130.21573604060913 I-145.87055837563452 J-32.68781725888325
G2 X287.20304568527916 Y125.14467005076142 I-140.10659898477158 J-5.073604060913706
G2 X285.42893401015226 Y102.89593908629442 I-140.19796954314722 J0
G2 X278.7690355329949 Y78.21065989847716 I-121.38832487309644 J19.51015228426396
G2 X266.5888324873097 Y54.90609137055838 I-107.97208121827411 J41.59137055837563
G2 X249.78426395939084 Y35.421319796954315 I-91.89340101522843 J62.253807106598984
G2 X228.94416243654825 Y20.327411167512693 I-75.08883248730965 J81.74111675126903
G2 X204.69289340101523 Y10.164974619289339 I-56.55076142131979 J100.94416243654821
G2 X179.5304568527919 Y5.619289340101523 I-34.31979695431472 J118.05837563451776
G2 X152.16751269035535 Y6.256345177664975 I-10.444162436548224 J139.80964467005077
G2 X125.28426395939086 Y12.073604060913706 I18.04060913705584 J148.39593908629442
G2 X98.56345177664976 Y23.15482233502538 I49.535532994923855 J157.21065989847716
G2 X73.28680203045685 Y39.317258883248726 I78.99492385786802 J151.37309644670052
G2 X50.48984771573604 Y60.233502538071065 I110.69289340101523 J143.54060913705584
G2 X31.581218274111677 Y84.72081218274111 I133.48984771573606 J122.6243654822335
G2 X17.616751269035532 Y111.2741116751269 I143.55583756345177 J92.44162436548223
G2 X8.83756345177665 Y138.83756345177665 I152.06345177664974 J63.60659898477158
G2 X5.317258883248731 Y166.11675126903552 I145.87055837563452 J32.68781725888325
G2 X5.225888324873097 Y171.19035532994926 I140.10659898477158 J5.073604060913706
G2 X7.00253807106599 Y193.43654822335026 I140.19796954314722 J0
G2 X13.66243654822335 Y218.1218274111675 I121.38832487309644 J-19.51015228426396
G2 X25.84263959390863 Y241.4263959390863 I107.96954314720813 J-41.59137055837563
G2 X42.64720812182741 Y260.9137055837563 I91.89086294416244 J-62.253807106598984
G2 X63.484771573604064 Y276.00507614213194 I75.08883248730965 J-81.74111675126903
G2 X87.73857868020303 Y286.16751269035535 I56.55076142131979 J-100.94416243654821
G2 X112.89847715736042 Y290.7131979695431 I34.31979695431472 J-118.05837563451776
G2 X140.26395939086294 Y290.0786802030457 I10.444162436548224 J-139.80964467005077
G2 X167.14720812182742 Y284.26142131979697 I-18.04060913705584 J-148.39593908629442
G2 X193.86802030456852 Y273.1802030456853 I-49.535532994923855 J-157.21065989847716
G2 X219.14467005076142 Y257.01522842639594 I-78.99492385786802 J-151.37309644670052
G2 X241.94162436548223 Y236.1015228426396 I-110.69289340101523 J-143.54060913705584
G2 X260.8502538071066 Y211.61421319796955 I-133.49238578680203 J-122.6269035532995
G0 Z1
G0 X259.505076142132 Y210.74771573604062
G1 Z-2 F200
G2 X273.33756345177665 Y184.4441624365482 I-142.21065989847716 J-91.57614213197971 F200`

1 Like

So it’s not the file. Clear Z- moves.

If you would add or remove a - in the Maslow setting, it would solve the problem for the file, but the Z buttons would be opposite and you could not Z0.

Not sure where to go from here.
Is this the latest FW/GC 1.25?

Edit: I see the makercam metric problem with the up to 16 digits and sent my sled in orbit with that in the past.

Would you try if changing a other setting helps?
-> In GC click on settings and then on the grey bar with title ‘Maslow settings’.
You should see an options for ‘Advanced’
If that’s clicked, there is a button to cut off those numbers, ->truncation.

Can you turn that on and see if it help?

yes, fw and gc are 1.25. Where i need to add or remove this - ?

What will happen if i put - in step down, like -2?

  • Is this your first run with the Maslow?
  • How did the calibration go?
  • Did you change settings without restarting everything (including unplugging the arduino)?

If the Z-axis buttons work correctly after all is restarted, adding the - for Z pitch would inverse those buttons and is not recommended.
Lowering your Z with the Z menu should show you on the right down side:

G00 Z-10.0

right? (10 is the amount set to move)

Advanced configuration change, but can try only tomorow. fw, gc are latest 1.25.These are first cuts with maslow, About restart, after calibration it need to reboot arduino? and about -10, yes i have 10mm plywood

1 Like

Checking wit CAMotics there are also issues with arcs. (kind of confirming the digit issue)
With what was the .svg for makercam created?

Svg’s are made from exported dxf in solidwork, then online converted to svg

1 Like

Is a sidewards ‘egg’ what you want to cut?
CAMotics and bCNC show this:

This was only test shape for my problem.

After that makercam.
I would look here.

Although there are issues with FW/GC1.25 this does seem more related to how the file is created.

But if you think it is the Firmware or GroundControl:

  • use the ‘wipe eeprom’ in GC
  • delete or rename → groundcontrol.ini in your ‘user folder’.
  • redo all calibration steps until success.

Report back