Maslow Home Maslow Community Garden Newsletter

Gcode/Program stops and disappears soon after the first cut

I’ve used the M2 Maslow for 8 different projects and for the most part I haven’t had any issues. But now, it will not cut whatsoever. Here’s what happens: I boot up the maslowverse software and check calibration. I always check calibration before a cut. I then make sure its centered and at home position. I upload the program/gcode and press play. It moves to the first cut, the bit goes down and starts to cut. As soon as it starts to move while cutting, the program/gcode disappears and the sled stops after a few seconds.

After this happens, I cannot move the sled. Maslowverse is locked. The only remedy I found to get the sled to move back to home position is to remove the USB cable and restart masloverse. I have tried this 4 times and get the same outcome everytime. I’ve restarted my computer, made double sure the USB has a good connection. Checked all the other connections to the arduino: motors, power, and communication.

I’m unsure what to do at this point and I need help.

Is it the same gcode line when it stops? Can you show the first few lines of gcode?

1 Like

We fixed the problem. I’d swapped the USB cable to a different port. So I moved it back to where it was plugged in previously and it worked.

2 Likes