Lost Connection Middle of Cut

I lost USB connection at line 1017 out of 11k lines. re calibrated the chains and moved to center. Everything is working fine on manual move but when I try to start the Gcode at the spot I lost connection, I get motor sound like its moving but its not moving.

If I start over from the beginning, the Maslow moves like it should. Any Ideas?

Also, I just noticed when I am cycling through the lines of gcode it jumps from 4% to 96%. It failed when it was on 8.8%

No clue whats going on but it think i have it going again. I’ll report back when done

USB connection lost again. I have not had this problem on any other cuts.
usb is seated fine
no sleep settings

Well shoot, that sheets ruined.
No connection errors this time but the gcode stopped scrolling through, the motors just kept running away.
Hitting stop didnt shut anything down. I pulled the power as the chain hit the end of its length.

I could imagine an inches/vs mm issue causing that problem. If one of the first few lines sets the machine to inches or MM mode it could end up in the wrong mode when skipping those lines. The same could be true if the speed is only set early on then the machine might not want to move unless the speed is set.

One solution could be to let it run for the first 100 lines or so without the sled attached, then jump to where you want to resume.

I’m a little more stumped here. Would you be willing to post the file giving you all this trouble? Did everything return to normal when the power was re-attached?

1 Like

This is what I ended up doing. That’s what I thought too. I copied the first few lines of the gcode and pasted it before the line I wanted to start but it didnt work. Starting from the beginning, pausing, and the moving to the spot I wanted worked.

I recreated the gcode and I no longer have the 4% to 96% skip when cycling through. I changed usb cables, moved power cables around. I’m about 15 minutes into the new cut. I’ll let you know what happens.
Thanks for the reply

1 Like

If I can clarify, does hitting Stop interrupt the current G-code line? I am thinking that if there was a unit conversion issue, then perhaps the runaway was caused by the machine trying to move the wrong distance, and hitting stop did nothing until the line was completed. Just spitballing here.

Yes, it does exactly that. The motors are halted, the program cannot be resumed. You can see the current line number, though, so you know where in the .nc file you were. It might be possible to step through the file to a previous G00 movement to resume from there.

Thanks. Guess that wasn’t it. Unfortunately that raises a concern over the Stop button not functioning as expected.

A deep dive into the log might add information, but it sounds like one of the encoders wasn’t reporting movement. The motor would continue to run, but the gcodes wouldn’t advance. A loose plug could be the culprit, I’ve had that happen on the z motor.

I’m assuming I lost usb connection due to radio static and ground control just didnt report an error.

Earlier in the project I lost connection and the motors ran away on the same path they were on when connection was lost but it only went about 5 inches before ground control reported an error and the motors stopped.

I moved power away from the usb cable, used a shorter cable and i have not had that issue since.

2 Likes

I had the same lost connection issue and bought a 4’ usb with ferrite noise reducers on each end and that solved my problem as well. I would suggest that as a swap for anyone, its really cheap insurance to not ruin a cut over a comms drop out.

3 Likes

Well it just happened to me in my maiden voyage. About one minute in it said it lost connection. I couldn’t do anything (or didn’t know what to do). Now ground control thinks my “defined home” for that cut is where it lost connection (which is way off). Do I really have to re-calibrate? Why would a lost connection throw that off that bad? I would think the “return to center” location is almost hard programmed into ground control once calibration is done and nothing can destroy it.

Only the ‘calibrate chains’ part. The lost connection would cause this if the USB port sent to sleep, killing off power to the Mega board. The sled position is saved a couple seconds after movement stops. but if the power is lost that can’t happen.

Just the chain calibration is needed. I always do the automatic one because at the end of the automatic my sprockets are slightly off 12. I’m afraid the manual way will be slightly off the cuts that have already been done.

The main thing that helped me was to move the sheild power off of the power strip that has the router and shopvac. Also, disable any power management settings. If you are still having problems, get a shorter usb cable, add ferrites, dont run power along usb, or find a shorter sheilded usb cable.

1 Like

Thank you both for your replies. See comments below.

Are you referring to “Set Chain Lengths - Automatic?” I just did the full calibration but skipped everything but sprocket tooth at 12 o’clock and let it measure out each side. Is this what Set Chain Lengths - Automatic does?

I can’t image USB going to sleep after only two minutes in. I read about this a while back and disabled every power setting I could find. Power was never killed to the Mega board.

I care less about where the sled is in a cut than I do where the center of my Maslow is. With the center of the Maslow being retained, I can then restart the cut. With my center getting screwed up, the temporary home for the cut got screwed up and there was no hope.

Shield power and small USB powered fan are on one power strip, vacuum and router are on a different outlet (and soon to be different breaker). Disabled all power settings I could find. Shorter cable wont work for me due to my setup. I just bought a USB with ferrites on both sides. I also moved the USB cable away from the power cord for the motor shield. They ran in parallel for about a foot, now they are slightly farther apart. Hopefully this solves it.

Hard to believe it can be as simple as turning on a drill (I think Bar said that) to loose a connection. This has be worried since so many things could cause this. Hopefully the ferrites fix this.

Yes, it’s a link to the same two-step procedure, without having to do the ‘skipping’ :blush:.

The USB cable with ferrites will be a good thing.
Other things that can cause the ‘lost connection’ include contention with some other program over the USB port or a connector not fully seated.

What I did:
Ran Set Chain Lengths - Automatic. Mark the link that is on the top tooth(take note of the position of this tooth) after the chains have been fed to a know position.
Next time I need to recalibrate chain length, I run set chain lengths - automatic, Define 12, extend left and right(without the chains on) put marked chain on top tooth

In the forums, I read that people move a tooth to the 12 position put the marked chain link on the tooth and then click Set chain length -Manual. However, I am not too sure how accurate this is. Whenever I do a automatic chain length there is never a tooth at exactly 12 when the know fed length is done.