Maslow Home Maslow Community Garden Newsletter

Gcode won't go under 2mm after using touch plate

Hi Yall, I need some help with the z probing. I enabled use of Touch Plates in Web control and it appeared to work perfectly. The z axis goes down touches and sets a great zero.
Unfortunately after using the touch feature, Gcode wont go below 2mm and will no longer run z axis movements from gcode after being asked to go below 2mm. It follows the g code until it tries to go under 2mm and just stops moving with no error. Manual gcode g1 z0 does not move and hums until I click stop but Z still moves with the arrows. So I tried manual resetting z after it froze but it won’t cut again until I reboot the PI. I tried multiple files with the same result. I am running webcontrol 0.94. Currently i have to run the touch then reboot then run the gcode. I must be missing something as it always stops at 2mm.

Here are the last few lines from my ALog. It tries to lower and stops moving so i stop the job after a minute or so.
9585.73: N0
9585.75: G0 X237.9900 Y-35.090 Z10.000
9587.33: ok
9587.33: Sent: M3
9587.34: M3
9587.36: Turning Spindle On
9588.34: ok
9588.35: Sent: N1 G0 X238.7480000000000189 Y-36.436000000000007 Z4.000
9588.37: N1
9588.40: G0 X238.7480000000000189 Y-36.436000000000007 Z4.000
9589.58: ok
9589.58: Sent: N2 G0 X238.7480000000000189 Y-36.436000000000007 Z2.000
9589.60: N2
9589.62: G0 X238.7480000000000189 Y-36.436000000000007 Z2.000
9590.04: ok
9590.04: Sent: N3 G1 X238.7480000000000189 Y-36.436000000000007 Z-2.540
9590.09: N3
9590.11: G1 X238.7480000000000189 Y-36.436000000000007 Z-2.540
9597.90: Sent: !
9597.91: ok
9597.93: Turning Spindle Off
9597.96: position loaded at:
9597.98: 238.75
9597.99: -36.44

Thanks in advance for any suggestions.
John

Hey Yall,
I tried reloading WebControl and various other stuff without success. Then I found that setting a speed (g1 f800) resolved the issue. I am generating my files with Vectric and using the Intellicam mm Post processor that I saw recommended somewhere in this forum. I don’t see any “F” codes in my files. I assume that means all my cuts and moves have been running at the default rates? Is there a reason the touch probe makes the system forget the default travel rates? Is there a better post processor to use with Vectric?
Thanks for reading this,
John

GRBL post processor?

1 Like

Hi Rob, I really appreciate all your efforts here.
Could you repeat your response with maximum verbosity to help me understand?
I am kind of new and you identified a hole in my understanding of things. I have been googling but I still have a lot to learn. I thought Webcontrol only supported basic Gcode and you had to switch to Makerverse to use GRBL?
I have to pick a PP in vectric to output the gcode. I have been selecting “Intelicam GCode (MM) (*.nc)”. It only outputs G0,G1 with xyz and a few G2 with xyij but no F feed settings.

John,

I didn’t mean that to be terse, but I really don’t know vectric and maybe the post processor selection might help. You asked about a postprocessor on the vectric platform. I must disclose that I know really nothing of vectric other than it is a gcode generator. In principle, the maslow post processor available on some platforms is a GRBL post processor with a more limited output command set. I do know that both the webcontrol and groundcontrol interpreters/senders and the mega firmware will read a limited subset of GRBL but are not considered GRBL compliant. Specifically it has issues (or had issues depending on the firmware version you use) with the radius (R) gcode and a number of other relative axis offsets are not implemented. I use carbide create and estlcam. Both work well with the grbl post processor. My response was just to ask if you had tried that one, but I was feeling lazy and didn’t put in any background.

The F setting is the feed speed and is important so you can get the right cut quality depending on the wood you are using and combined with your cut depth can dramatically affect your total cut time. Does the intellicam system have a set feed speed so it doesn’t need to get that from the gcode?

1 Like

Thanks again Orob,
Its one of those thing where I could test a “better” PP or just use the one that spits out the most basic code. Also I figured the default feed rate was slow enough not to have to worry about the speed. Thats pure lazyness on my part.
I installed the vectric-easel.pp and will try it next to see how Webcontrol likes the code. I read someone else had issues but i think their issues were unrelated to that PP.

JT