Ground Control link

When I click on the releases page link in GitHub I get this everytime.

I get the normal list, including 0.87. Same for the firmware. Not to be that guy, but did you try the obligatory (browser equivalent of the WinDoze 3 finger salute) clear the cache?

Gosh, been recommending that since 1995 and Netscape 1 (or maybe less than 1). Scary.

Twice now and still same results. I’d never visited the releases page before. So didn’t think to try it, but I did it twice like I said for good measure and still get the 404

GitHub hates me :sob:

Oh and I tried signing out of GitHub and signing back in. No luck.

Have tried in chrome now and same results.

Bout to go try another computer.

same results on two different computers and 3 different ios devices all with multiple browsers. On both wifi and cellular :confounded:

I have no idea…

I don’t know if that is an old link or something, but the proper link is:

1 Like

That was it!!! Your link works…

Thank you much…

Here’s where the releases link leads

Thanks for catching that, where is that link so I can fix it?

1 Like

in the readme here Where it says releases

1 Like

Thanks again for pointing that out! The link should be fixed now

1 Like