Home offset after every cut

So I’ve been standing out in the cold watching Garth cut away. I had 4 cuts in 4 quadrants of a sheet of plywood. Garth is my 6x4 maslow and so when I cut, typically I do half sheet, move and then the other half. There are reasons for this and they won’t change, so it is what it is. I find that I home at a y position of 2’ from the bottom of the frame and an x position of either -2.5 feet or + 2.5 feet and have a comfortable 4x5’ cutting area that is pretty accurate.

The issue I am finding is that I’ll home on the left, cut the upper quadrant, and when complete, the home position will be off by a cm or so. I mark the home position on the workpiece as a matter of habit and often cut a 2 mm deep hole so it can be used. This last time it was off, I reset the chains. Each cut completion has a different variance of how far it is off, might be a mileage thing, but it seems that one of the steppers is losing steps and so my cuts in some places appears like steps.
My run times are about 1-1.5 hours per quadrant and the offest is 1 - 2 cm roughly. Seems cumulative, but I could be way wrong. Using a custom shield with TB6643 chips and modified firmware to support the board.

Has anyone experience this before? My thoughts:

  1. Initially the right motor was suspect because it was dropped and broke the encoder plastic cover. I taped the cover back on and it seems to work ok AND the offset in the home position is up to the left. (if a longer cut, it is off more). This last one was 4mm left and 3 mm up.
  2. moved the left cable to ensure it wasn’t an electrical interference thing.
  3. I thought the sled was rocking because the UHMW thing on the bottom of the sled had twisted and it was not laying flat… fixed that, sled is flat, still have offsets.
  4. realigned router bit with center of ring to make sure it wasn’t a rotational offset problem
  5. looking through the settings, the only value that seems suspect is the rotational radius for the sled is 87.4 instead of 140, but I think I measured that.
  6. The left chain tolerance is 0.02 and the right chain tolerance is 0.979
  7. I have another gen 1 shield on the way, so I’ll try with that as well and see if the offset persists.

In summary, I’m trying to figure out if it is a hardware or software problem. I don’t like what it is doing to my product and I’m hoping one of you have seen this and fixed it.

If you swap you x and y motors does the offset follow. That may rule out the motors being the culprit.

good idea. I have a third I was thinking about swapping in as well. if the drift continues and I just offset home, I’m not sure if it will eventually think it is off the page… so I need to reset home after every offset to make sure it isn’t too far off. I just put on 3d printed chain stays and so resetting is a pain until I can get the right sized wing nuts…

Update on observations: changed new motor with motor on right (dropped one). reset chains, ran for 60 minute cut. still offsets

changed motor on left with motor from right. rand for 60 minute cut, still offsets.

Changed gcode to do 2 pass instead of 3… less offset per run, which suggests it is cumulative step creep, but no idea why, though it manifests as a creep in the upper left direction. I’m using a variant of firmware version 1.28 with a T6643 shield. Perhaps the braking on the shield is not activated correctly or it is coasting?

Next step: swap shields and see if it changes. Motors do not appear to be the issue

if the chain is jumping a tooth at some point(s) during the cut, that would
explain this sort of issue.

check your wire routing, try not to run AC power (especially for the router)
adjacent to the motor signal wires.

Just like you are testing swapping the motors to see if the problem follows the
motor, also try swapping the cables to see if the problem follows the cable.

David Lang

Thanks for the suggestions and input!

Jumping teeth: that was my first thought and I installed 3d printed chain guards. No jumps that I have seen and offset still a problem. If a chain jumps, I would expect the sled to be off lower than the original home position. The offset is climbing up and to the left.

Cabling: I do have shielded cables, but the shields are not grounded currently. I’ll try connecting them and then swapping them.

Wire routing: I quickly tried isolating the power, but I’ll go back and look at that again and see if that can be done better.

Thanks for taking time to think about this with me. I’ll keep trying.

Here is a pic after today’s cut of the offset

Ok, so I put on chain guards:

The top guards held on by the wing nuts are removed in both pictures.

I changed the motors in a round robin and found that they all do the same thing. More on what might be the issue behind that later.

This is a 1.28 modified version for my specific shield with TB6643 chips on it.

I just came across an original maslow shield with the 2 chips, so with a separate mega, I swapped both the mega and shield out, flashed holey 1.29 and recalibrated. First calibration was 6mm and good enough for 15 degrees with frozen hands, so I loaded the file I had just run. It cut the first hole in the home position ( a good recommended habit should you need to reset chains and restart the cut…). The z axis safe move position is 4 mm. Here is what it does:

It plunges to -6.75, then up to .5 mm , then to -13 mm, then to - 6.25 mm, then to -20 mm, then back up to 4 mm, but it never makes it to 4 mm. it gets to -4 mm or -5 mm and takes off for the next point.

The move to 4 mm in the z direction is a G0, where the others are G1, so I inserted a line just before it:

G01 4.0000

and then the next line was

G00 4.0000

and it still doesn’t retract all the way. But I found when trying to set the sprockets initially that the power connector was temperamental and would sometimes not power the board. The power cord to the shield is loose in the connection and it is zip tied in place, plus it is freezing cold in the garage, so the cord is rather rigid. If bumped, the power LED on the shield will flicker, so perhaps the shield is losing position by losing power, but the mega still has usb signal, so it doesn’t pick up on it. Since there are feedback encoders it should keep trying. This should not happen like stepper motors lose steps, so I’m at a loss.

One controller has issues with X-Y and the other has issues with Z.

Super frustrating. I did find that the ideal initial chain payout on Garth (the 4’x6’ system) is 1524 mm though and is really close to center.

Thoughts on how to fix this are certainly welcome. Rewiring the shield is an option or using the spare power supply.

actually, the encoders don’t measure the absolute position, the measure
movement, so just like steppers, if there are hiccups (power issues, connection
issues), they won’t report movement (or if the problems are timed exactly wrong,
they can report movement in the wrong direction for a step)

David Lang