PySerial Install SyntaxError

You are correct - however this is the instruction set from running form source, and if Kivy is getting the wrong video driver information it will still fail.

If this is a Windows / Kivy video issue I have a USB bootable linux image up on the file share at:

desciplesofcnc.com

It requires a legacy bios option to boot form USB.

Thank you

3 Likes

Hi Bee,

Sorry for any confusion here. I had installed a clean Windows 10 Pro 64-Bit on a 10 or so year old laptop. The Kivy error is related to a driver issue where the OpenGL requirement to run GC at a minimum is OpenGL version 2.0. The onboard graphics driver upgrade is unsupported with Windows 10. I need to downgrade to Windows 7 in order to obtain a supported graphics driver. I’m hoping that by installing windows 7 my Mobile Intel 4 Series graphics card can update and the OpenGL version will be 2.0 or higher…To be continued

Yep - I’ve seen this and I wish there was a way to skip it. There are times Kivy will still report the wrong Open GL in it’s check. This is an issue with Windows Drivers and Kivy not working well together. This is well documented in Kivy development. Because it’s a Windows specific issue, using “NOT Windows” is a workaround. It’s the sole reason I made the USB boot image of linux. Unless you plan to never use the internet there are compelling reasons to not run Windows 7.

I also have a setup running a Raspberry Pi3 / Ubuntu as a remote desktop that is rock solid. That is ~$60 setup.

Thank you

1 Like

My first go around with this Dell laptop, I installed Ubuntu 17.10. Alas, I’m not very well versed in Ubuntu and was having a difficult time trying to get PySerial & Kivy to install properly. When I would run python main.py there would always be some type of error. I made sure I had python 2.7.x. but I couldn’t figure out what directories files were being downloaded/installed to as I’m used to Windows.

1 Like

The USB bootable image I made has the prerequisites installed you just need to DL ground control. If you can setup the firmware on Windows you can then boot the USB image DL GC and run it.

Linux has a learning curve for sure. I’m trying to get my Raspberry Pi solution ready to release as well.

Typically Linux puts the download in the current directory you are in.

I believe with Pyserial once it’s installed you want to do an immediate upgrade.

Thank you

Kivy is broken in Ubuntu 17.10, the workaround was solved in this post.

I think the key is to run pip with linux requirement text in the GC directory.

pip install -r requirements_linux.txt

2 Likes

You know, I did see that requirements file, but I wasn’t sure how to implement inside of terminal. I might just try this tonight with a fresh install of Ubuntu again and see what happens. Thanks Jamtek

1 Like

Ok so, I was able to update the windows drivers for the onboard graphics card but Kivy does not seem to realize that my OpenGL is 2.1.

The Kivy Error is shown below

image

Yep - Sorry you are seeing this, it’s a know issue. Because we rely on Kivy and it is a windows / Kivy issue your options are limited. I helped another user with this issue with the USB linux in a post mentioned above.

Move to different hardware, or a different OS.

I have a long article on why to not use any thing below Winows 8.1, I suggest Windows 10 in the Wiki. However that is security advice it will not resolve the Kivy issue.

Thank you

I also have an old Dell Latitude E6400 with Intel Mobile 4 series chipset, maybe similar to what you have. I converted to a Chrome book with NeverWare, cloud ready desktop. The laptop is primarily used by my kids for school work, but I also run Ubuntu 16.04 LTS Linux on it via crouton and I am able to run Kivy and Ground Control on it without issue.

The point is it looks like you gave up on Ubuntu 17.10. You could try Ubuntu 16.04 Xenial Xerus, which is the current Long term support build and supported until April 2021. Ubuntu 17.10 broke a number of things not just kivy.

https://wiki.ubuntu.com/Releases

The Linux on a stick I have up is based on 16.04. - FYI

Thank you

Hi Jamtek, I haven’t had a chance yet to install ubuntu again. I was trying to exhaust all my chances with windows first. For some reason I am unable to update to the latest driver, im able to download and install it but the system will not take the driver update. I just realized that this is the reason why Kivy throws the error.

I will try again here shortly. I just don’t know how to update the driver through unbuntu.

You shouldn’t have to worry about the drivers in Ubuntu, they should already be the latest open source drivers.

Also as be mentioned there are also other community distros built on 16.04

https://xubuntu.org/tour/

to name a few.

1 Like

Ok so I’ve installed ubuntu 17 onto a different HD. I followed the installation steps and this is where I’m stuck.

Jamtek, Bee you or anyone else your help is greatly appreciated.

Try the Linux on USB for Maslow from the website

https://www.disciplesofcnc.com

Create a free account and go to the files download. Your using V17 instead of 16.04 of ubuntu. The suggestion was to try 16.04 - however seeing it in 2 OSs may point to a real problem with the Graphics Card.

Thank you

It looks like there may be a kivy issue for that open here:

with some different work around options proposed here:

1 Like

Try downgrading Cython , and try to run it again.

sudo pip install Cython==0.23

You may also need to login with Xserver not Wayland, which Ubuntu 17.10 defaults too.

Not sure what version of python comes with 17, but you can find out by typing -> python -V in the terminal. If it shows a 3 in the front, you need to start GroundControl with -> python2 main.py

2 Likes

Since the source for Kivy is readily available is there a way to beat it over the head and skip the buggy version test? Then offer a version of GC for those with the right hardware that fails the bad test.

I requested this at least 2 months ago - it only heard the sound of crickets at that time. I second a option to bypass the check, however this is Kivy dev so forking is going down a slippery road.

But you live in a swamp so you know slippery!

Thank you