WebControl RaspberryPi Install from Image file

I posted my experience in the wiki going headless, first using this image, second using the pyinstaller. The image took hours to download and multiple reboots, it might have been my WiFi but I was showing errors. I’ve done the pyinstaller version a couple of times, took much less time.

The first time getting the docker going was frustrating. I thought it had a corrupt file system so I re-imaged it after a 5 minute wait only to find out that this is normal. After the new image was installed, I left it for a good half hour and it runs fine.

The second pi I have set up with pyinstaller, and it went fairly quick, but it has not been connected to the maslow and used to cut yet. I’ll update when I can provide comparison information.

I’ve had the docker system (not just webcontrol docker, but docker itself) just fail for no apparent reason and couldn’t get it to work again without reburning a whole new image. And now I’m struggling with getting the docker built because of the modules needed for the documentation system.

1 Like

Docker (version 0.913) is working well, but I want the LED functionality and so I want to switch from the docker version to the pyinstaller version 0.920. How is it done without reimaging the sd card? Thoughts on what services need to be killed on it before doing the install? or can I just drop files in a specific directory? and do I just move the webcontrol.json file to maintain the settings?

EDIT: for fun I just swapped the SD cards from my two RPI 3’s, so the maslow now has 0.920 on it and the same gcode will not show up on the board for the latest pyinstaller version. It appears to upload correctly and can be selected. The loading visualizaiton occurs, but then the picture of the cutout on the board does not appear… on the screen. It is miles down below the cutting area. I imported the previous settings json file and restored the backup. Same thing: solution -> right click on sled position and set as home, and it is fine.

just shutdown the docker version and follow the install instructions for the
pyinstaller version. You can uninstall docker if you want as it’s no longer
needed at that point.

the singledirectory version for the pi just has you download the zip file,
create a directory, cd to that directory and unzip the software, it really is
that simple.

David Lang

The pyinstaller version is super easy to get working, but how do you turn off the docker version so they both don’t start when it reboots?

There is a typo on the github writeup for installing the pyinstaller version. the wget file name and the tar -zxvf names don’t match. One has 0.920-rpi and the other has 0.920-linux so if you try to cut and paste, it doesn’t work without a little edit. Not a dealbreaker, but if you are just wanting it to work, it won’t and the “… backslash” in the tar line needs to be a “…forward slash”

There’s is a setting in webmcp to disable autostart of docker-based webcontrol. Disable it and reboot to make sure it gets disabled. You could disable webmcp from starting as well (its a systemd service) and that will prevent docker-based webcontrol from starting.

Thanks. take a look at it now and let me know if I got it right :slight_smile:

Yeah. I noticed that happened to me this morning. Something is going on with home.

the github page is close, but the tar command doesn’t work as typed…

the directions say make the directory, then go into it and get the gz file

the tar file says to go back one directory to find the gz file and untar it, so I’d do this:

cd ~
mkdir webcontrol
cd webcontrol
wget https://github.com/madgrizzle/WebControl/releases/download/v0.920/webcontrol-0.920-rpi-singledirectory.tar.gz
tar -zxvf webcontrol-0.920-rpi-singledirectory.tar.gz

and rather than make the service file and copy it, I’d make it in the correct location to start with:

sudo nano /etc/systemd/system/webcontrol.service

one other optional add is to install samba, so if you are using windows, you can just drop them in the gcode folder on the rpi and open them in webcontrol rather than upload and then open, they are already there and you just open the one you want. My gcode generator now puts them there automatically. It dawned on me that I could do this with the git repository location instead of trying to keep two separate copies (one on my laptop and one on the rpi in sync).

sudo apt-get install samba samba-common-bin
sudo nano /etc/samba/smb.conf
(set mask to 775 or 777 for items in there)

add these items into the file at the end

[global]
netbios name = MaslowPi
server string = Maslow File Drop
workgroup = WORKGROUP
[MASLOW]
path = /home/pi/
comment = No comment
writeable=Yes
create mask=0777
directory mask=0777
public=yes
[GCODE]
path = /home/pi/.WebControl/gcode
comment = No comment
writeable=Yes
create mask=0777
directory mask=0777
public=yes

sudo smbpasswd -a pi
sudo service smbd restart

Fixed that… made it simpler as well (I think)

I’ll try that out.

Hey folks,

because I had destroyed my samba in the end after failing to make the raspberry a drag and drop drive in windows i finally reinstalled the Imagefile. With the help of orob (thanks @Orob ) I could manage to make everything work.

Today after plug the raspberry to the Maslow in the basement i imported the ground control.ini file and wanted to start cutting a project.
Quickly I realised that the Maslow is not moving correct any more…
When I say move right 10mm it drives a crazy path (diagonal right/down) and there is the warning

ALARM SLED NOT KEEPING UP

Also when I try to move the z axis the Maslow just moves in some direction…
Just seems that if I send the signal to move it does not know where “right” ist

Did I missed something? Where this error comes from?
Hope to find a solution soon…was just about to do some fronts for sound diffusors :frowning_face:

Try resetting the chain lengths.

You had it working in ground control and you took the groundcontrol.ini file and imported it to webcontrol?

It worked when I went from groundcontrol to webcontrol. If you are using the computer that had ground control on it, do a quick check comparing the settings transferred from groundcontrol to webcontrol, or reimport the groundcontrol.ini file. The last option would be to recalibrate with webcontrol.

Does red reticle (crosshair) on webcontrol display match where the sled is in reality?

@madgrizzle, you think it lost its absolute home position?

If the controller lost track of the chain lengths, the position it reports back to webcontrol could be different than where the sled really is. For example, it thinks both chain lengths are 1600 mm (so it says it’s centered horizontally) but in reality, the sled is way on the left side and chain lengths are actually 400, 2000… then when you tell it to move right, it computes how much chain to feed out from the left side and how much to reel in from the right side. But it’s not the correct amount considering where the sled actually is so the sled doesn’t move right, it moves down and to the right because too much chain is let out from the left side (when on the left side of frame, less chain needs to be let out to move to the right… so the sled drops to drop due to excess chain being let out)

1 Like

Thanks for your input!
While I tried to set the sprockets vertical i found out that the left sprocket did. move close to 360 deg when I send the order to move 1 deg!!
In the end it turned out something with the cable-connection was wrong!
After unplugging and plug-in again it worked again! :man_facepalming:

4 Likes