How Do I Install? Raspberry Pi Image for WebControl

Hi all,

There’a topic for the “sort of” prebuilt image for Raspberry Pi, but I just created an “actual” one, so I thought I’d start a new topic for it.

So, I just published the first release of my pre-built WebControl image for Raspberry Pi. It can connect to an existing Wifi network, and will fall back to creating its own if it’s out of range.

See all details here:


Awesome! This is VERY much needed for RPI installations.

1 Like

Awesome! I was just trying to use the other prebuilt today. So this should work for a headless install?

Yes, I’ve been testing it 100% headless, actually. Only issue I had was that it was trying to connect to my house Wifi from the garage, which is just out of range, so the access aoint was toggling on and off. Once I un-configured my house Wifi (by just plugging the card back into my computer and editing the webcontrolcnc-wpa-supplicant.txt file), it worked very well.

Haven’t really done any cuts yet, but I did upload some old files, and jogged around a bit, no issues.

how did you get the headless option to toggle? I tried to do it and didn’t get it to work properly.

Not sure what option you’re talking about here… I’m talking about operating the Raspberry Pi without any monitor / keyboard attached, which should work “out of the box” with that image.

And another silly question: do you keep the quotations around the ssid and psk in the webcontrol_wpa_supplicant file?

Yes, keep them in.

New problem. My router shows that the Pi is connected, but my router does not show it’s IP address (or any other computer). Anyway to specify a static IP address in that document?

I guess I would have to do it in the dhcdcd.conf file. I have been having a problem accessing ext4 filesystems, guess I’ll have to figure that out if no-one else has a suggestion.

Nevermind, I tried the last IP address that another Pi install used and it worked. So I lucked out. I’d love to hear other solutions though.

I mean the AP / Wifi toggle for the headless image. Unclear question. sorry.

There’s no toggle, it’s automatic. If it can’t connect to a network, it will create its own.

Is that access point feature something you added? I’ve been able to set up the rpi as an access point, but not do both.

It’s built upon the work of guysoft for Octoprint, see here:

The documentation for the AP feature specifically is here:

The behaviour I’ve observed in my tests is that if I configure my wifi details in webcontrolcnc-wpa-supplicant.txt, it’ll connect on boot, but if I’m out of range it’ll create its own. Configuring wrong details or not configuring it at all will also make it into AP mode.

You need to uncomment the relevant part of the configuration in that text file. Don’t forget the country part near the bottom, or it might not have the correct channels for your router.

So I’m able to connect to port 5000, is 5001 no longer necessary? (I’m unable to connect to it).

FYI I’m a first time Maslow user, just got my kit yesterday.

I’m a recent Maslow user as well, got mine a bit less than a month ago. I’ve been lurking here for a while, though. I’m also a new WebControl user (was using GC because all my Raspberry Pis were tied up in other projects), so I’m not actually sure what port 5001 was used for. I think I saw something about Docker and updates related to that, but we’re not running Docker on the Pi in this image, and I tested the update process, which should work by just clicking “update” and waiting for a while.

So unless I’m missing a feature (which I can look into adding), port 5001 is indeed no longer necessary.

Ah, ok that makes sense. I’ve been reading quite a bit on the forums and it sounds like the docker version is history.

What firmware are you planning on running? I’m thinking about the Holey implementation. Thoughts?

I’m running the stock firmware at the moment, but I’ll definitely try the holey firmware soon. My machine is a work-in-progress; I don’t have any z-axis for now as I don’t have the standard Ridgid router (hard to find in Canada; the only available one has a plunge base which I don’t want / need), and I’m waiting on my C-channel to show up from Aliexpress. After that I’ll probably upgrade to a 12-foot top beam or something.

from the webcontrol docs, port 5001 was for WebMCP:

WebMCP is “supervisor” program that can be used to start, stop and upgrade WebControl. The advantage if using WebMCP is that it provides a means to monitor and control WebControl from a browser. If WebControl seems non-responsive or something is amiss (it is still alpha-software), you can use WebMCP to see its health and stop/restart WebControl if needed.

1 Like

I didn’t realize the AP functionaity came from the octoprint work. Thanks for incorporating it. I tried to roll my own and ran into several roadblocks.