Where do you adjust the plunge rate in Gcode?

Post the first 20 or so lines of the gcode… maybe we can figure out what’s going on from it.

This is the feed rate (in the gcode, it’s the number after the F in the Z
movements)

The value that limits the z-axis speed is found in Settings.cpp of the firmware, on line ~86 - maxZRPM. It is currently declared as 12.6.
You can try different values. Be advised, this setting may have strange results in gcode files that do coordinated x-y-z movements :wink:
The easy way to play with this setting is to program one of the GC macros to send the value.
$18=12.6
would send the default value. With a meter on the bench,
$18=20.0 seemed to cause the drive voltage to maximum, higher values didn’t seem to make a difference.
My sequence was to change the macro, use the macro button to send it, use the Z-axis panel to test it.
Let us know what your find :grinning:

Once you settle on a $18 value, you can try values for F (feedrate) in your gcode file as @dlang suggests.

1 Like

Thanks. I searched the Gcode and there is no reference to the letter “f” in the entire file.

Here is the first 30 Lines

G20
N0 G0 X0.0000 Y0.0000 Z0.7500
N1 G0 X-4.2426 Y4.2426 Z0.2510
N2 G1 X-4.2426 Y4.2426 Z-0.7500
N3 G0 X-4.2426 Y4.2426 Z0.2510
N4 G0 X-4.9497 Y4.9497 Z0.2510
N5 G1 X-4.9497 Y4.9497 Z-0.7500
N6 G0 X-4.9497 Y4.9497 Z0.2510
N7 G0 X-7.2565 Y-3.9158 Z0.2510
N8 G1 X-7.2565 Y-3.9158 Z-0.7500
N9 G0 X-7.2565 Y-3.9158 Z0.2510
N10 G0 X-3.9158 Y-7.2564 Z0.2510
N11 G1 X-3.9158 Y-7.2564 Z-0.7500
N12 G0 X-3.9158 Y-7.2564 Z0.2510
N13 G0 X3.9159 Y-7.2564 Z0.2510
N14 G1 X3.9159 Y-7.2564 Z-0.7500
N15 G0 X3.9159 Y-7.2564 Z0.2510
N16 G0 X7.2565 Y-3.9158 Z0.2510
N17 G1 X7.2565 Y-3.9158 Z-0.7500
N18 G0 X7.2565 Y-3.9158 Z0.2510
N19 G0 X4.2427 Y4.2426 Z0.2510
N20 G1 X4.2427 Y4.2426 Z-0.7500
N21 G0 X4.2427 Y4.2426 Z0.2510
N22 G0 X4.9498 Y4.9497 Z0.2510
N23 G1 X4.9498 Y4.9497 Z-0.7500
N24 G0 X4.9498 Y4.9497 Z0.2510
N25 G0 X0.0025 Y-1.3750 Z0.2510
N26 G1 X0.0025 Y-1.3750 Z-0.1875
N27 G1 X0.0000 Y-1.3750 Z-0.1875
N28 G1 X-0.0355 Y-1.3745 Z-0.1875

So it’s taking about 35+ mins to drill one 3/4 deep hole. :frowning:

1 Like

@madgrizzle - Yes - Stock design w/ Stock Z-axis.

Thank you @blurfl
I appreciate your help. Unfortunately, I’m not that technical and don’t even know where to begin to modify the settings.cpp firmware file (latest as of Jan 1). I don’t even see this file on my PC when i search for it.

Here’s the first few lines of something from makercam. It’s a profile cut and does passes at 0.05 depth increments. Seems like Vcarve Pro is missing somethings (not all lines below are recognized by Maslow).

(Generated by PartKam Version 0.05)
G20 G90 G40
(profile 1)
G0 Z0.5
T0 M6
G17
M3
G0 X9.375 Y8.125
G1 Z-0.05 F30

The F30 is 30 inches per minute…

G20 = programming in inches
G0 = rapid position
G1 = linear interpolation.

Looking into the Gcode file, it looks like some better settings choices in the V-carve program might be a help here. What is the bit size you’ve told V-carve to use? What is the hole size you want to drill? Should they be the same? It looks like V-carve is drilling holes .75" deep then moving 0.0001" and doing the same again. That doesn’t seem right…:thinking:

1 Like

@blurfl
We are plunge drilling 1/4" holes to a depth of 3/4"
The bit we are using is a 1/4 spiral cut end mill.

Try changing thhe line
N0 G0 X0.0000 Y0.0000 Z0.7500
to be
N0 G0 X0.0000 Y0.0000 Z0.7500 F40

That will tell the firmware to use the maximum travel rate. How big is the file?

@blurfl - Same result. The file size is 111kb

Could you .zip the file and attach it to a message in this thread? How many holes are there? Is there a way to set the tool height during travel (something lower than .25” so we won’t have to wait as long for it to rise)

I have no idea about the Maslow G code yet. I am stil waiting patiently on mine, On the Hass I program at work, an F40 command would tell the mill to run at 40 thou per min. F4.0 would be 4 inches per min

@Kris , @TITTIGER_MASLOWCNC,

Here is a link to a web page called Gcode to English Translator , a great resource to dig in and understand what’s going on in each line of a file.
@Kris, the Haas machines are much more sophisticated than the Maslow, I’m jealous :grin:! The Maslow firmware tries to interpret gcodes in the same way outlined in the grbl project. Numeric values are interpreted as inches or millimeters, depending on a setting.

1 Like

What postprocessor are you using? The one you picked is generating gcode with no feedrate.

I’m not a VCarve user, too spendy, but it’s been mentioned here by other users so somebody should be able to say which pp they’re using.

VCarve, like a lot of CAM programs generates gcode in (effectively) two phases. It first decides how it wants to move the tool and generates a (call it) meta code that specifies it’s full capabilities. It then feeds it to a type of program called a post-procedure that translates/strips down the meat code to the dialect (there’s a whole lot of em) of gcode your machine supports. In your case it’s absolute bare minimum, feedrateless simple moves only. I’m guessing other than the initial set inch mode (g20) that file is only g0 (rapid move, no coordination between axes, some machines will use each axis’s fastest speed and might take a curved or zagged path) and g1 (coordinated linear moves, i.e. straight lines). That’s a lot simpler than what you can use, even if the Maslow isn’t up to Fanuc sophistication.

Or Haas…

This looks to me like the issue could be that the feed rate is not being specified. The G0 command (moving to where the hole should be drilled) will run at the right speed because G0 moves are done as fast as possible, not at a specified speed. Once drilling the hole commences the machine starts to move REALLY slowly because it doesn’t know how fast it is supposed to be going.

I bet that there is an option in vcarve to fix this because it is very standard to specify the speed. To confirm that is what is going on I would try editing line N2 to look like this: N2 G1 X-4.2426 Y4.2426 Z-0.7500 F1000 We clearly can’t move 1000mm/min but that will just make it go as fast as possible. Once a speed command is sent that speed is assumed for the all of the following moves so you shouldn’t have to make any other changes.

Let me know if that works, and if so let’s try to find the right setting to tweak

3 Likes

I found a topic from September saying to use the x-carve post processor. I’d link to it but the G5+ is being recalcitrant

@bar Thank you! The F1000 command worked. I am using the Vcarve Intelicam_GCode_Inch.pp post processor as recommended here: https://github.com/MaslowCNC/GroundControl/wiki/CAM-(G-code-generation)-programs

Is there a better vcarve PP to use?

1 Like

Your first line says to move the Z axis to 0.75 inches above the work, the second to 0.25 inches above it, the third to 0.75 below it, i.e. the full thickness of the work. In other words it’s moving from (likely, but it depends on where you left the bit) zero to 3/4 of an inch up, then an inch and a half down. Since we use a sled that slides over the work nothing (like clamps) sticks up above it. Most CAM software has you set a clearance height to miss the stuff sticking up, usually called a safe height. Since nothing sticks up with the Maslow set it to something small like 0.125 inches (or whatever Bar recommends) and save all that crawling up and down. Look around and see if there’s another option for clearance, like a special initial or start or end value that’s set to 0.75 and reduce that too.

VCarve has better post processors than the speed less one you’re using. Unfortunately I can’t help you find which one to use. Vetric, however, has a well attended forum that can help you. The Maslow supports speeds and arcs, that should be enough to get you some help. I’ve read that the grbl pp won’t work, but that could be a false rumor. Surprised that one of the current users hasn’t commented

1 Like