Maslow Home Maslow Community Garden

Z-axis motor only turning one direction


#1

Hi All,
I’m in the final stages of my initial setup and the Z-axis motor is now turning in only one direction. I first started having problems doing the very initial calibration but noticed the cable was not fully plugged in to the motor. Firmly seating the cable into the motor seemed to fix it. I was able to finish calibration and cut the final sled successfully with the z-axis working well throughout the job.
Now I have moved all the hardware to the final sled and I’m repeating the calibration. However, the z-axis will only lower and not raise. I thought it was the cable again, but I’ve checked the connections on both the motor and the board. I disassembled the z-axis mount and removed the shaft coupler. The motor is only turning in the “lower” direction when I send commands from GC. When I send the “raise” command while holding the motor in my hand, I can feel a “pulse” but nothing turns. Seems to be a bad connection either in the cable or inside the motor itself. I would swap cables and do more troubleshooting, but I only have one z-axis motor and one cable. Any ideas? Are the cables or motors known to go bad (or be built bad at the factory?) Thanks much!!


#2

Try swapping the motor cables after marking your chain position and removing the chains. Is the issue on the Z motor or the z motor port?

Thank you


#3

Thanks for your quick reply Bee! I’m not sure I understand your suggestion. The chain motors both seem to be working fine. The cables feeding the chain motors have a different connector than the Z motor (at the motor) so I can’t swap between chain motor cable and z-motor cable. The problem seems to be the connection at the z-motor.


#4

Swap the connections on the motor ports of the controller. All 3 are the same there. The motors can be driven by any of the ports for testing. This is a process of elimination.

Thank you


#5

OK, that makes sense. I’m shutdown for the evening but I’ll give that a shot in the morning. Thanks much!!!


#6

So I went out to start troubleshooting and tried to repeat the problem but now everything is working fine! The only thing I had done was shutdown Ground Control and re-opened it. So I assume that must have reset something that was preventing the Z-axis from moving properly? I’ve completed the calibration and done a few test cuts and everything is working fine. Hopefully the problem does not reoccur. Thanks!


#7

This problem has come up for me too… I am performing my first calibration. It was working just fine, then I needed to quit the calibration to adjust the z axis pitch and that seems to be what triggered it. I closed then reopened GC but no dice. Since I’m in the middle of calibration, I didn’t want to swap cables as @Bee suggested since, correct me if I’m wrong, the controller would loose track of where the sled/chains are and I would have to go through the calibration again? I don’t want to wipe the controller for the same reason.

Any other ideas?


#8

That is very strange. My instinct is that it is a hardware issue because it seem to crop up infrequently so my first suggestion would be to unplug and re-plug the z-axis cable. You can do that safely without worrying about messing up your calibration.

If it is a software bug the only thing I can think is that the z-axis is starting out in an unknown state. What does Ground Control report the z-axis position as? (it will be the lowest of the three numbers reported over on the right side of the screen. That is the machine’s current XYZ position)