Maslow Home Maslow Community Garden Newsletter

Z target depth issue

I have a MetalMaslow I am using Easle to generate my G-code. I am seeing inconsistant Z-depths. I thought it was an issue of slop in the Z but if I look at the current position in ground control while the machine is running it shows that the Z is not traveling to the requested depth in the G-Code. EXAMPLE: My code is calling for .062" steps, my first depth will hit anywhere from 0 to -.020". the next pas should be -.125" and will hit anywhere between -.060" to -.090" the depth showing in Ground control matches the actual depth of the cut. I am cutting multiple pockets and some run worse than others. I see a lot of posts about loose z axis and bowed material and that does not seem to be the issue here since the position on ground control seems to be correct just not the target called out in the g-code. Any ideas?

This sounds to me like it could be the setting for how far the z-axis moves per rotation of the motor. Basically different kits use different pitches of threaded rods. I bet @metalmaslow can hook you up with what that pitch should be in the settings.

If I am reading your problem correctly I am having the same issue. I have been fighting it for days. I am taking 4 equal passes at -.1875. First pass program runs to Z-.1875 but ground control says the z is at -.146, final pass runs at Z-.75 but ground control reports cutting at -.620… I let the program run through and then I programmed to run one pass at Z-.8 and it only went around -.680.

I stopped and was measuring the actual bit depth when I told ground control to go to -.75 and it was dead on. I turned on the router and manually plunged to -.75 and it went through the board. For some reason, Ground Control won’t go to the programed depth but I can make it manually go there. I am completely at a loss. I am experienced with CNC G-code (I have a CNC manufacturing degree) but this is my first experience with Ground Control.

I slowed my z travel speed from 15in/min to 7.5 and it seems to be working fine. The only thing I can think of is the motor could not hit the target depth in the programs allotted time so it moved to the next line of code and the z axis was left wherever it got to. Not sure if this makes since but the slower feed seems to have fixed my problem. What speed are you using?

1 Like

I’m programmed at 15in/min, I will slow it down when I get to the shop tomorrow morning and see if that fixes it. Thanks!

Yep, That worked. Thanks!

1 Like