Maslow Home Maslow Community Garden Newsletter

2 fried arduino mega2560's

This is the board I assembled:
http://maslowcommunitygarden.org/Maslow-Brains-Motor-Shield-formerly-Blue-Smoke-Herder-Shield-.html
I used the files directly from the github source:

Without power connection there is no short between 5V and GND and 12V and 5V.

The only place that 5V comes near 12V on that board is in the area of the motor connectors.
Is the Vin trace connected to the 12V trace at J11? If so, does disconnecting that change the result?

Edit – not 112V!

Which scale on your meter are you using? With the continuity function of the ohms scale, you should get a beep tone when you touch the probes together.

1 Like

@Bee, any thoughts on this issue? There don’t look like many places for 12V to short to 5V.

We put together ~100 boards and had, no issues with the shield to date. The only issues reported were resolved by unplugging and plugin the motors back in. Where did you get the TLE chips? We went with Digikey and Mouser for our parts.

Did you get more than 1 board made? Do you have an empty board to start with probing?

Thank you

2 Likes

The Vin trace is indeed connected to the 12V trace at J11. How can I disconnect them from each other?

I got the TLE chips at digikey as well. The boards I had manufactured at aisler. I actually have 2 spare ones that I can probe. But then I should also apply the new probing board, no? Or do I just check if there are some shorts on the board?

If you found shorts on an unpopulated board that would be a place to look on the populated one.

Can you post a picture straight down overhead, clear from Edge to Edge?

Also same from the bottom of your board? Sorry on a phone- I didn’t usually write on a phone, fat fingers.

Check to make sure that there are no shorts between the 6 pin ICSP headers on the Arduino Mega and the bottom of your shield. Specifically the 6 pin header on the Mega and the leads to the 1K resistor/Power LED on the bottom of your shield. I made the mistake of not cutting the leads back enough and well, pop went the Arduino.

Harry

1 Like

Thank you guys for the support, I am sending attached the pictures that Bee requested. They are from a populated and an unpopulated board (from the same assembly batch).

photo_2019-07-28_21-56-22 photo_2019-07-28_21-56-22%20(2)

So nothing is jumping out in the pictures. Have you tested the Power Supply by itself to see what you are getting? The consensus is there is a short somewhere and you will need to work your way around with a meter to find it.

I hope that helps

Thank you

Thank you. I am thinking to desolder the board and populate a fresh one, and put more effort into having it soldered clean.
Then I hope whatever mistake there was, might be solved…
I will let everyone know if I find what has been causing the issue.
cheers
zuse

It might be a good idea to do a continuity test between 12V and 5V on the new board before adding parts, and maybe occasionally as parts get added :wink:

1 Like

Is there a possible connection between the backs of the TLE chips and the heatsink? I see that bee used nylon bolts to hold them down, and you have used metal bolts…

A good thought, but I just checked and the tab is grounded, as is the heat sink.

That might be the voltage regulator the LM1117 I believe…they really can’t handle a ton of power and running 12vdc in makes the regulator get hot…and usually smokes

There are repairs…but they ain’t pretty
Fix a Fried Arduino Mega

1 Like

I tried fixing it with a standard replacement, like the same voltage regulator. But I think I will give that “frankenstein” version a shot on the arduino that is still recognized by the computer!

I ran across another replacement that might even work better (pinouts match the original so you don’t have to criss cross the leads)

The LM1085

2 Likes