After the Automatic Calibration, The chain retraction

Good Morning All!

After a week or 2 being too busy to mess with my maslow, I’m finally back at it.

I have my linkage system all hooked up and working great! what a genius way to make sure the bit doesn’t deviate from its position.

Anyway, I upgraded my firmware to .99 and ground control to .99 at well. I then went to calibrate chain lengths. I accidentally calibrated the machine without changing to triangular Kinematics. the machine calibrated just fine. I was then working on getting my machine dialed, realized what I had done, switched it over to TK and then attempted to dial the machine in using the new system, made a calibration cuts, and on the second set of cuts, the machine lost chain position for some reason.

so i went to calibrate again, went through the whole process and hit finish and the chains begin to retract, i thought they would stop retracting after a few seconds, they did not. the continued retracting until almost pulling the sled apart. i had to slip the chain in order to release the sled. just thought it was a fluke so i re calibrated the chain lengths, and this time i didn’t reattach the sled, hit finish and the chain on the left motor retracted the entire length of chain that had just been run out, i hit stop in ground control to stop the left motor from rotating without the chain on the gear, as soon as i hit stop the right motor starting doing the same thing. i hit stop again to stop the movement of the right gear.

and here i sit. what is going on?


I experienced this before, but don’t know what eventually solved it. I think I had a zero in the field that you are told you could skip (measuring between chain mounting points) if you are using triangular kinematics. Go to advanced settings and if there’s a zero there, but something not zero in (and obviously set it for triangular kinematics there if its not). This might solve the problem.


Thanks! I’ll give that a shot.

1 Like

I had the same problem with .99 at the end of calibration. the chains retracted and brought the sled up right over the work surface until there was too much tension for it to continue. I could hear the motors struggling and they stopped but continued to buzz as I think they were still trying to retract.

Pretty much the same thing just happened to me… I changed board thickness from 1/4 inch to 1 inch, so I decided to calibrate with test cut. The first cut came up at 1911 mm, 6mm from where I need to be (1905mm/75in.)
Test cut round 2:
I press the start test cut button, the motors started retracting and sled started to near the top of the frame I knew that something was wrong. I pressed stop motors, and the auto calibrate trying pop-up came up, but the motors continued retracting! So, my “big red stop button” to cut power to the motors was to pull the cable to each motor as quickly as I could… The sled had just started teetering off of the top of the sled. Whew, n here I am.

1 Like

Yeah, I see it too. clint your’s is particularly scarry. Mine at least gave the the recalibrate message after I hit enter value.

Let me see what I can find.

1 Like

Anyone else having an issue where they can’t change from MM to inches there as well?

Looking at my settings after the fact, I suspect that is at least part of my issue. I clicked it nothing happened, clicked it a few more times, then said whatever and entered the value as MM.

As alway, thank you Kevin!!! :grin:

I fixed at least the error that was preventing my calibration from working. Try this branch for GC and let me know if this works


I got my Machine all calibrated up this morning, some how some astronomically huge number replaced the rotation radius, changed it back to 270mm and it is working great. going to make my first real cuts today!


It works, and is important. Without this fix, if a user clicks the ‘MM’ button, the units text of that button does not change, but the numbers typed in will be evaluated as inches though it looks like a metric number is required. A metric value evaluated as inches gives a wildly wrong rotationRadius :open_mouth: , and since there isn’t currently a reality-check on the value, so craziness ensues.


I can’t test at the moment as I’m running a long sequence, but FWIW:

in addition to the ‘climbing to the top and nearly breaking stuff’ others saw, when mine went into this state two other things occurred:

  1. the machine would only go up. trying to move down, left, right, or control the z axis, made it move up.
  2. the next time (and the time after that) that I tried to recal the chain lengths, it would not let me complete… kept complaining about invalid position and chain length (even though I was trying to recal the chain length). I was not able to continue until I finally in desperation cleared the eeprom, reloaded the firmware and did a full recalibration.

I guess the glue joints on the new linkage kit were good. (nothing pulled apart at least.) :slight_smile:

No fix is required immediately, but eventually is necessary. refrain from clicking the millimeter tab and just convert to MM before entering. this worked for me and is slightly easier than updating software

I’m glad the linkage didn’t break! The strain on the glue joints is almost entirely shear, and standard titebond wood glue (not even the premium or titebond III) has a strength of 3,650psi. The glue surface on the E parts for example is .75"x8" which is 6 square inches, that means the strength of the glue joint is about 21,900 pounds. I’m sure there are variables that will change that number but I’m pretty sure something else will fail before the glue joint. I have not been able to break a linkage kit yet (I’m sure I could break one, but I want to be able to measure the stress it can handle when I do). I strain tested the kit that I put together for the instruction pictures and each linkage withstood more than 85 pounds without breaking. And the clevises held 145 pounds (without any glue at all (and without breaking)).

When things go awry it is possible for the motors to produce as much as 66 pounds of force each. This is unlikely and would only occur if the sled was pulled quite high off the top of the work area (I believe I calculated 8" above the top of the work area equates to around 66 pounds for a 20 pound sled). For normal use the max is around 33 pounds (could be a bit more due to friction, bit depth, path direction, etc.).


SOunds like it’d be smart to add some sort of mechanical break away at the sled? Eh but then you’d have a wild router swinging, double edged sword lol

1 Like