Strange calibration issues

So I recently updated my machine to 1.0 and added a kinematic kit. After chain calibration, any move I make causes the sled to lower in place. up. down, left, right, and Z, all cause the sled to move down. My maslow was working fine before, any idea what I’ve messed up or setting I’ve botched?

Side note, I might need a replacement Z motor. I made the mistake of going to the bathroom while I was running the calibration cut, and the sled simply dropped to the ground and rested all of the weight on the z motor which now wobbles about.

Ouch - that hurts, I’m sorry to hear that happened. Have you tried to roll back the the previous version?

Thank you

I had the same issue, I restarted the calibration from scratch and once the calibration was completed correctly, the issue was fixed. Not really sure what was causing it though.

1 Like

Generally when I see this behavior it is occuring because the machine can’t calculate it’s position based on the chain lengths. Is the calibration message popping up when you start GC?

Is it possible you entered the rotationradius incorrectly?


This. I had that exact same issue once from the auto calibration routine. Turns out the rotation radius was updated as a negative number. Also can happen if the number is too large.

1 Like

1.01 adds a ‘sanity check’ which will hopefully reduce the chance of this happening. Basically the ‘sanity check’ makes sure the math isn’t working with crazy numbers during the calibration process (like a negative radius). I’m not sure it’s a cure all, but it was a community suggestion (and I think a really good one) from someone else who saw the same behavior


@krkeegan is correct, I now remember setting the rotation radius correctly and that was what actually solved my issue! Wow my memory failed me quickly lol


The same thing happened to me. After installing a kitematic kit after chain calibration any move caused the motor to drop to the floor. ( I think I was on .99 ) I did still have a Distance Between Sled Mounting Points value set. After upgrading to 1.0 and setting Distance Between Sled Mounting Points to 0 I was able to get through the calibration and hit the test cut length.

My settings still show a ‘Vertical Distance Sled Mounts to Cutter’ value. I’m not sure if this should also be zero’d out when using triangular kinematics.

those values should be ignored, but if for some reason they aren’t, you should
have them set to 0

the only values you should have with triangular kinematics is

distance between motors
yoffset (distance from the top of the workpiece to the motors)
rotation radius

the foloowing two should be at their defaults (unless you are using different

link length

teeth on the sprocket

@bar, is there any way that these values being set could be throwing things off?

I don’t know (I don’t think so) but I think that is an important to be sure of. I will check it out and report back

1 Like