Arudino/shield Trouble Shooting

I moved about a year ago, and after waiting for some upgrades from Metal Maslow I have everything back together again. I update the firmware in webcontrol and attempted to calibrate, but there is a grinding noise coming from the Arundino/shield when I try to adjust the right motor and it does not spin. The Left motor works fine. I have run the motor test and all motors seem to operate fine.

Is there way to tell if one of the two parts are bad, or should I replace them both. If they need replacing any recommendations on where to source the parts?


Hi @Tim_Dow, a noise from a electronic shield that has no moving parts is difficult for me to understand. Can you explain more? It would be the first time that someone uploads a sound file and might seem stupid at first, but experienced can differentiate sounds I guess.

The forum is not allowing me to upload a file. But it is not the normal whine when the motors turn it has a little grind sound with the whine. I had always thought the whine came from the motors, but to my surprise they run quietly in during the motor test.


The upload restriction is only until you get a few likes and responses. That’s why I like and respond. A video would be cool to narrow this issue down. If it takes a little chatting to get you there, so be it.

I have had many experiences with electronics when a short would occur and produced an audible sound. Occasionally it would self destruct but sometimes it could be found upon a very close inspection. Perhaps a grounding wire is touching power someplace.

Would that not be a “fizzling” / “sparking” sound?

1 Like

That seems normal sound to me. So the issue is that there is sound but no movement?

Maybe it is hard to hear, but they do not make the same sound. If you feel it sounds normal, then yes the issue is no movement.

It will spin when I run the motor test.

Ok, down to the details.

  • Supplier of the kit
  • Is this a Mega Arduino or a Due
  • Any warnings / hints from Webcontrol
  • The OS this is running on

Kind regards, gero

I’ve had a grinding noise happen when the cable wasn’t firmly seated into the motor… I had thought I lost a gear because of how it sound, but turned out to be a simple fix. Intermittent connection.

1 Like

Might want to check the settings to see if any of them are way out of whack. The motor test bypasses everything and just applies a voltage to the motor and reads the encoder values to make sure they turn in the proper direction. A move function, however, does a lot more… it involves PID loop and all the kinematics settings. When you go to set sprockets vertical, all of those moves bypass the kinematics, but uses the PID loop and a few settings (chain pitch and number of teeth on sprocket). Check the settings for something odd.

This is one of the originals I purchased from from Bar about 3 years ago.
It has the Mega Arduino
No hints from webcontrol that I can tell. Webcontrol is new to me though, I had been running the same version of ground control I downloaded 3 years ago.
It is running on Windows 10

1 Like

I am getting the message, “unable to find valid machine position for chain lengths 1661.3, 1815.77 please set the chains to a known length”

What are this upgrades? If mechanical, ignore.
I have heard all kind of sounds from the motors.
Where exactly are you stuck? Are you attempting a calibration and it does not work?
What firmware are you running in Webcontrol?

New Sled and Top Bar
I was attempting to set the sprockets so a tooth is straight up.
I am using the stock firmware 1.26

Here is a video of the 360 degree rotation for some extra sound

Woah… that’s not right. Check your cables again.

I have tried to plug the left cable into the right motor and swapping cables. I do not think it is a connection issue unless it is on the board. I do not see any damage or broken solder points on either piece though.

that sounds like a gear jumping at 4 seconds in the video or a woodpecker. A while back we had a woodpecker that would come and peck on our metal fireplace exhaust. Sounded similar to that.

Always the right motor, regardless of cable swap?