Right motor still not working

I have updated to the latest firmware, uninstalled Ardunio, reinstalled and the right motor will still not turn.

Let’s figure out what’s gong on. What happens if you run the Actions -> Test Motors/Encoders?

Please see attached

Great! Well not great, but at least we know it’s not the same issue we were seeing before. What happens if you swap which motor is plugged into each side? Does the problem move with the motor or does the Right motor still fail?

I plugged the cable from the left motor into the right motor and could get it to move through Ground Control

It seems like it must be an issue with the Arduino shield then. I think the quickest thing to do is to get you a new one. Would you be willing to email Hannah (hannah@maslowcnc.com) and let her know you need a replacement Arduino Shield? I’ll tell her in person, but having an email makes sure you won’t get lost.

Emailing her now, thanks!

Sorry for the trouble! :disappointed:

I have replaced the Ardunio shield and my right motor will still not move…

scratch that, seems to be working now… thanks for the quick shipment!

1 Like