Calibration issues motors not turning

I am doing the initial calibration after building the system. I installed the software. I went into Ground control put in the measurement from center of sprocket to top of plywood(had to do it in mm) . Went to move sprockets and they don’t move. What do I do.



Is the 12VDC plugged into the motor shield rather than the arduino (both boards have plugs… need to plug the power into the motor shield). If so, run Test Motors/Encoders and see what messages you get.

When I run the test USAID that the firm ware may not be installed. I went through the firm ware install. Now when I run the test it says nothing

do the motors move?

Not at all

Have you selected for port in settings?

I did it in adreno under tools

Is this settings in Ground control?

Yes, go to actions (if I recall correctly… been long time since I used ground control).

I believe the menu option you want is Actions -> Ports

Now it is bouncing back and forth from connected to not connected

From connected to connection lost

Connection timed out

make sure you don’t have the arudino software running at the same time, you
don’t want the two softare package fighting over the port

That behavior means the firmware is not installed correctly.

Which set of instructions are you following to set this up?

Thanks for your help. How do I make sure the arudino software is not running?

The one in assembly on the Maslow cancel site.

Maslow cnc site

Is it these instructions?

Can you post a screen shot of what the arduino program looks like after uploading the firmware?