Big trouble in a little country (left motor doesn't stop spinning after setting chain length)

Another message from the lowlands:

I had my Maslow up and running and was pretty pleased with the first results. But, on the first real major cut GroundControl had a pop-up stating that it lost the whereabouts / location of the sled and I should set my chain length again. The sled stopped and I could see on the screen that the red circle was in the middle of the workarea, but my sled was still on the left side of the workarea.

I first checked all the hardware. The heatsink had fallen of my board which probably caused the loss of location by GroundControl.

I set my chain lengths again, but after extending the chains they are still to far apart to attach the sled. Possibly this is caused by the length of my beam (360cm / 12’) instead of the stock 10’. So I clicked on “move to center” to get more chain. The left motor starts spinning and doesn’t stop, until I press “stop”. The right motor doesn’t spin. I have performed this step several times and the outcome doesn’t change. If I continue without “move to center” the pop-up for setting the chain lenght pops up immediately.
I also performed a manual calibration based on the values from the back-up log-file I have from the last time the Maslow did work.

The question is, did I destroy my board, do I have to do the calibration all over, or is there a single button that can solve all my problems :wink:?

The “motor keeps spinning and doesn’t stop” thing sounds like a connection issue to me. If the encoder pulses aren’t getting back to the controller then the motor doesn’t know when to stop. I would start by trying to press Actions -> Test Motors/Encoders if you see any issues I would try swapping where the motors are plugged in. If the problem goes away it was a loose connection, if it stays with the same plug side on the controller it is a controller thing. If it is an issue with the controller I can send you a new one right away.

1 Like

Ok, there is progress,

Ran the Test Motors/Enoders. All three axis went back and forth.
I checked the cables and indeed the cable of the left motor was a little loose. Plugged the cable back in ran the Calibrate Chain Length again. Both chains extended (adjusted the .ini-file to 2.032 mm extending). The new problem is that now when I press “Move to center” both motors retract to the point that there is about 2 feet of chain left on the workarea-side of the sprocket. So if I had put my sled on the motors would have pulled against each other.

Is a full calabration (non manual) my next option?

1 Like

This sounds to me like one of the dimensions that the machine thinks it is is way off. The lengths the chains adjust to for move to center are based on it’s understanding of it’s own size so having the chains move to a very short length probably means that one of the measurements is off. If you just want a clean slate you can press Actions → Advanced → Reset settings to defaults which will get you back to known reasonable values for everything

1 Like

Problem solved!

Resetting to the defaults didn’t do the trick, but a full non manual calibration did.
In the end the problem and the solution were not that hard, so lesson learned. Next time I will go through the entire process of checking and calibrating the machine before I call in the Maslow-cavalry/community.
@bar thanks for your patience.