Cannot "calibrate" or "set chain length", motors wont move


I am trying to calibrate. I cannot rotate the motors to position a tooth to 12 o’clock position.

I have run the “test motor-encoders”, and motors move normally, and GC reports test is passed for both motors

But when tryng to calibrate, and using the buttons “move 1 degree ccw-cw”…or any other value in degrees (5, 360…) motors don’t respond.

Once it moved 1 degree, but further on, there was no movement at all.
I got the error:

I checked the topic: and did the following…

  1. Removed the bricks from the sled to make it lighter… no change
  2. Ran again the motor test, continues to report test for both motors are ok.
  3. How could I increase the power supply?, which is the other suggestion in the topic… I just connected the us power supply provided to my house’s power outlett…, Do I need to get another hardware to do this?..this is the only option left to try for me in this topic

On another related topic, someone was suggesting do this calibration without the sled attached. I did so, I removed the chains from the motors. Still the motors didn’t move when trying to set one tooth to 12 o’clock position.

Sometimes motors make noice, but no movement. When pressing again the rotate x degrees buttons, there is no further sound or anything.

Tried just to move 10mm upwards…, it requieres chain lenght calibration.

I am stucked at this issue right now.

You could try resetting everything - On your computer, find ‘groundcontrol.ini’ in your home directory and change it’s name or move it somewhere else. That will reset GroundControl. Then start GC and use ‘Actions/Advanced/WipeEEprom’ , to clear out the Arduino. Then restart GC and see if that helps.

1 Like

thank you so much, I have been able to set the tooth to 12 o’clock possition… I am on the calibrating process right now.
Kind regards

1 Like

Hi @blurff

I have finished the calibration process, but I am still having issues.

When I try to move manually, no matter which direction I select, the machine is moving left always.

It is asking for chain length calibration also, but I found the instructions vague and imprecise.

Is there a way I can video or voice chat with somebody to help me with this?

The issue before comes out again, at some point the machine becomes unresponsive, and doesn’t move at all. I have move gc from place to place, and done “wipeEEprom”, several times, but it always becomes unresponsive.

Right now when testing the motors is not responding also.

Any advice will be much appreciated

This is really annoyng.
I have shut down the computer, and started it again.
The motor test works again,
but when I try to move manually, it starts moving, but it doesnt finish the task. It stops and asks for chain lenght calibration.
After this the machine becomes unresponsive to manual controls, or motor test.
I have moved the gc folder once and over again, but repeating this over and over again is nonesensical at this point.
In the chain calibration is not clear: Should I detach the sled? should I leave the sled attached? What is the machine going to do with this?
I tried whit the sled attached, started with the “left chain button”, it started to move the left motor, until a point the sled was getting out of the plywood sheet, almost into the ground. I stopped the precess. Really this step is not clear.

@blurfl I have manually calibrated the chains…
the manual movement is ok now…
I will procede to experiment further…
thank you so much


Hi @blurfl, I hope you are doing well

I am happy now testing empty paths (moving the sled but without cutting) in the machine.

The problem is that I am still getting the “not keeping up” error. If you remember I had this issue, even with no chains attached at all, just trying to rotate the motor to calibrate. Even so, I tried this suggested solutions:

  1. I made the sled lighter, in fact I removed the 2 bricks completely. No solution to the error. (and anyway as I said before error comes up even with no chain and sled attached, so I am assuming it is not a weight issue)
  2. I changed the folder in which ground control is to reset it. And used “wipeEEprom”. error still comes up
  3. I made the feed rate slower (tried from 60 inch/min to 50 inch/min). Error still comes up.

I am running the test motors command first every time I run a path. The left motor, most of the times, fails direction one, but on a second immediate test, it always returns passed in both directions. Maybe this bit of information is useful to find the problem. Also I do not have the need to press “stop” as suggested in a topic, since no beeping alarm sounds and the machine does not stop; just continues to run the path after clicking ok in the error dialog.

So at this point I am open to more suggestions.

There are 2 options I haven´t tried yet:

  1. Buying a more powerful power supply. (I am kind of reluctant to this: I have no electric background [it may sound silly, but I honestly would need specific details on the power supply to buy, and what to ask for, I am not confident with this purchase], and I live far away from major cities. Honestly I struggle to get a simple screw here in the town in which I live. Also the overall investment has gotten out of hand for me right now, so I am trying not to have anymore expenses. I would have to make a long travel in order to get this).

  2. Changing the motors from left to right. ( I would love it if this issue has another solution, maybe in a topic I haven’t found yet. I mean a solution related to software, solving it by taking actions in ground control or the arduino api, rather than disassembling the machine)

Please if you have another suggestion at this time , I would really appreciate it. There are a lot of topics in the forum, and I have the feeling that maybe you know or can direct me to a topic with different suggestions.

Thank you again for your previous advice, it was really helpful.

Spare me for the long text, and the whining about my personal issues and struggles, I just want to be as clear as possible.

Have a nice day.

The ‘cannot keep up’ error happens because we do not do acceleration planning,
and motors cannot move from stopped to full speed instantly. There is an
advanced setting that you can use to set the threshold for this error to be
reported, but with the current system that is just not reporting that there is a
bit of a problem.

Slowing down your feed rate will make this problem less, and in most cases it
doesn’t matter, but in extreme cases you could find that your cut is not
straight because one motor is falling far enough behind for you to notice.

David Lang

Ok, thank you very much.

What I am understanding from your kind response, is that probably I should just ignore the error due to the absence of acceleration planning.

I will start then running paths doing the actual cutting, and confront the mesures of the cut pieces. I am hoping as much as I assume you are, that I will have proper cuts with the right measures, since everything seems to be normal in my initial tests, despite the error dialog.

Thank you very much. @dlang please have a nice day.

Do try 30 inch/min to see if that makes the alert go away. Some users run with 40 inches/min, others get the alarm at that speed.

1 Like

Thank you very much @blurfl, I will try that speed.

Kind regards.

1 Like

the theoretical limit of the maslow is about 48 ipm, so you are still setting it
faster than the machine can possibly move.

David Lang

1 Like

Thank you. I started at 60 inch/min, because is the speed indicated in the guide about generating the g code for the sled using MakerCam and the provided .svg file of it.

Your information is very much appreciated.