Blinking red light, z axis work but no retract or extend works

Morning,

I set my maslow4 up, got it calibrated and working.
then a belt slipped off and got chewed up by the gears.

i took it all apart, fixed it but i believe the cable is pretty mangled(i’ll have to get a replacement)
but at first when i put it together, i kept getting an error and realized the arms were put in reverse (mixed the diagram up) so when i tried i got an error. realized my mistake and re-assembled

now the top board has a flashing red light. the z axis works but i cant retract or extend any of the cables. Not receiving any errors just says retracting and sits there. when i hit extend, nothing but to hit retract first.

Any suggestions?
Im updated the firmware and everything.
Thanks

1 Like

I had a similar problem recently. Check the connections of all your Ethernet cables.

1 Like

Thanks! figured out the cables were being weird so i checked them and all of a sudden she was working.

Now to get it set up and start cutting

Thanks!

2 Likes