Calibration Errors

Hey guys, new to the community. I’ve finished setting up the frame and hardware on my Maslow but I’m stuck on the calibration step. I went through the entire process and everything seemed to work fine until I got to the step in the picture attached. I’m not sure what’s supposed to happen at this stage, but the chain didn’t extend far enough to allow me to connect the router at both ends. I manually centered it by shifting the links on the sproket until they were centered. I continued to the next step which is the z-axis zeroing and here too I had issues. When adjusting the z-axis (I have the kit installed) the right motor would move more than the z-axis motor. Not sure what I’m doing wrong. I was thinking of reinstalling the firmware but maybe somebody has some better ideas. Thanks in advance.

Did you build one of the stock frames? Also, are you using one of the ring kits or linkage kits?


I manually centered it by shifting the links on the sproket until they were centered.

Don’t ever do that :slight_smile: You will throw off any calibration and will lead to utter, complete and head-banging frustration. We need to get you to the point it feeds out the correct amount of chain.

1 Like

That sounds like it could be a connection issue to the motors. I would check all the cables and then run the test to see if all is well by pressing Actions -> Test Motors/Encoders

1 Like

I am having a similar issue. When I extent the left chain it extends, measuring from the top of the motor, to 61". Then when I extend the right chain it measures 65". I am only measuring the part it extended. But Before this when you set the Gear to the 12oclock position the left motor moves CW when i click on the 1 & .10 CCW action. If i select the 5CCw it will actually move CCW but not very much maybe 1degree, because the 5CW moves a significant more. any ideas why this would be happening. This is my second time doing the calibration, the first time everything worked fine for the most part and i got some pretty great cuts out of it, except i got so chain skipping on the right side so i decided to do a bit of rebuild. i have a video of the issue as well the file is a bit big so i will share a google drive link. Left motor issue

1 Like

I actually did that exact test and everything worked as expected.

Sounds like we have a similar issue. Let me know if you find a resolution and I’ll do the same.

Have you checked to make sure you have good connections to the motors and controller? The only thing from a settings perspective that effects what command is sent when you press a button is the chain pitch (should be 6.35), number of teeth in sprocket (should be 10) and whether your chain feeds over top or bottom. To have the buttons behave different like that doesn’t sound like a ground control issue.

1 Like

In my situation I’m using all standard hardware sent directly from Maslow. Might it be a firmware issue?

I doubt its a code issue… otherwise we would have seen that before. when you do a “test motors/encoders”, does everything pass?

If everything is well connected, you might want to consider doing a “Reset Settings to Default” and a “Wipe EEPROM”

I went through and looked at all the connections. i have all my cables lightly ziptied about 6" from all connection points as to not have any tension on the actual connection junctions. They were all completely seated in their connections nothing out of the ordinary. But i decided to disconnect the left motor cable and re connect and go back to the 12 oclock setting and it seemed to be moving correctly again. I went to the next step to extend the chain length and they both extended to exactly 65" from the top of the motor. i had done it twice with the same exact results, but after unplugging it and plugging it back it back in i got matching results.


The old, “Did you unplug it and plug it back in again?” :slight_smile: As an I.T. Professional, I seriously use that almost daily, and 9 times out of 10 it ‘fixes’ the ‘issue’ :slight_smile: (The other time it wasn’t plugged in at all!)


All motors passed all tests. I’ll try resetting to default and wiping. Thanks for the tips.

UPDATE: Reinstalled arduino, firmware, and ground control to latest versions and it’s working fine now. Thanks for the help everyone.