Maslow Home Maslow Community Garden Newsletter

Maslow CNC Calibration problems

groundcontrol
chain
accuracy
calibration
z-axis

#1

Hello there, I’ve spent the last 2 days trying to get my Maslow going. I can’t get it to go to center after calibration. Weather I enter my values manually or let the machine do it. Either way I get errors. I’ve watch countless videos trying to retrace the steps to hopefully get it right one time. My final attempts last night, I got the furthest I was flowing the calibration directions and all was going good until it came to the z-axis calibration, when I went to do the z axis to the board instead of the bit moving up and down the whole sled started moving down, which was confusing because I just measured my to section them set my chain lengths with the y- axis and x-axis, so it really was confusing when the sled moved because the z-axis was supposed to do the moving. I’m eating so much time on set up, please help.

!


#2

Welcome to the forum! It took me six attempts to get through my first calibration. I also had some strange motor movements in the beginning that I believe were, in my case, related to two different issues that I had:

  1. Cable connections from shield to motors were not good. If you made your own connectors, verify that they are solid, unplug all the cables and plug them back in.
  2. I accidentally had two of the wires crisscrossed and it sort of worked somehow but caused strange behavior. I think the positive and negative might be swapped on one of the motor shield boards, depending on which board you bought, compared to the actual motor. Double check the pin outs and make sure that is correct.

#3

Thanks for getting back to me, I’ve been trying to connect in different ways like your saying to see if it’s my right/left, x/y axis problem, but still getting same results. And no I didn’t make anything myself, I’m not that inventive. I’ve just taken out out of the box and watched youtube and been on the garden to learn how to put it together. MakerMade assembled the board and sent it to me assembled that was great.


#4

Some more information on my issue. I’ll start out with my machine, I use the 10’ foot top 2x4. When I started out I thought I could just go the manual entry route, I measured everything, I input that in the settings menu. I used 1651 mm as my chain length (got that on the garden). So I go about the whole manual set up, the do the manual chain set up, but have problems and error messages through out the process. So I start from square one, close ground control, open Arduino, do the whole upload bit, close that, then go to GC, and I start the guided calibration process. I go through that and got a road block, machine won’t adjust chain I correct direction, or so I think, so I initially set up the motors x axis on the right side y axis on the left side as if the machine were you and if you were facing the machine the x-axis would be on the left side and the y-axis would be on the right side. Not knowing if that was a good thing and thinking this is my issue. I reverse that, now when looking at the machine x axis is right side and y-axis is on the left. So I redo the ports in Arduino, go to GC and start again. This time I get as far as the Y axis steps. When I tell the Y axis to plunge to hit the wood, it has the x axis and y axis move the sled down until it grounds out. Stuck right now on the bottom bar, I can just pick it up and move the chains but I feel I should be able to get ground control to move it.


#5

Got the new firmware download it have me issues at first but got help and figured out you need to go to the GitHub Maslow page to DL firmware and update seperate and then open the file in Arduino. Hopefully this help calibration.


#6

Ok. I’ve read through this a few times and its difficult to understanding what you are trying to say sometimes, although I think there are a couple of areas to look at:

Firmware - don’t worry about updating at this point. Focus on getting the basics to work.

With Maslow, the left and right “main” motors are not strictly X or Y motors. To move the sled in a straight line, in either the X or Y direction, both motors are required to move. The motor that moves your bit up and down can be considered the Z axis.

Please send a picture of your motor shield (there are different designs and not sure which one you have) and where the cables are connected (from shield to motor).


#7

Also from my side a Welcome!

Help us to help you.
The following information is essential to provide better Support:

  • Your Operating System with version (Windows, Mac, Linux)
  • Firmware and GroundControl version number you are using
  • Temporary frame / sled or final build (picture of your setup can help)
  • Chain mount system to the sled (Original brackets or a Triangular Kit)
  • is your slack-chain on the sides (top-feed) or over the top (bottom-feed)?
  • upload a copy of groundcontrol.ini from your users folder and the log.txt from the GroundControl folder (a clean log.txt is prefered and much smaler, delete the log.txt before you start GC, do the steps until the error shows up, close GC and post the fresh log.txt file)
  • does the ‘Test Motors and Encoders’ from the GC -> Actions pass all tests?
  • what is the motor distance you measure by hand?
  • what is the height of the motors over the sheet you measure by hand?

It is not very common, but possible that several failed attempts have left the arduino in a ‘strange mood’.
A clean start (wiping the eeprom and renaming the groundcontrol.ini) unplugging the arduino and reconnecting can get that solved. It’s recommended by me, that if you change settings in GC, close GC and un- and replug the arduino to make sure those changes are loaded.

In any case it will be a step by step approach to narrow down what is happening.

Kind regards, Gero


#8

Hi Park,

I have same issue on go to center sled wants to go off board low left. I have to stop it. Please ping me if u find fix. jr