Maslow Home Maslow Community Garden Newsletter

Chain not extending enough after calibration

#1

I’m a newbie here.
I mistakenly skipped a few steps in the calibration and did the chain length part first.
It ran each side out to about the middle of the frame.
I then realized that I missed the part about the distance between the motors.
Went through all the steps from scratch now three times and every time I get to the end where it should run the chains out so I can attach the sled, it doesn’t give me enough.
Left gives me about a foot and the right gives me 3-4 feet.
I see others have had similar issues, however I can’t seem to follow what the fix is.
Can someone please advise me on where I’m going wrong?

1 Like
#2

Welcome! You will find the answer in the Calibration wiki :slight_smile:

1 Like
#3

Thanks for the response but I’m really not understanding this.
I went to that setting and it was set to 1650, so I changed it to 1651.
Then I went through the calibration again from the beginning.
When I get to the part where I’m asked to extend the chain, it doesn’t come out far enough.
If I hit the extend button again it only comes out a little more, then even less the third time.
Sorry if I’m missing the obvious.

1 Like
#4

This last time I kept the chain on the left sprocket after setting the distance between the motors. It fed out more than before but still less than it does on the right side.
It’s just enough to attach the sled if I were to somehow hold it up towards the top of the frame. I was expecting it to run evenly from each side and enough so I could attach the sled from the bottom ledge of the frame.
Should I attach it at this point? Off center and towards the top?
Thanks for the help!

#5

I think that is the correct move. If I remember correctly the sled will move to the center after this step.

1 Like
#6

I missed that part earlier. That is strange. Some questions:

  1. Please provide details about your machine like: where you got your kit, frame type, any customizations?
  2. What version firmware and ground control are you using?

While waiting for the above, a quick suggestion that may or may not help:

  1. Unplug your arduino USB and power connection.
  2. Close Ground Control
  3. Connect arduino USB and power
  4. Open Ground Control
  5. Try the chain extend again.

If you are still having problems, upload your “groundcontrol.ini” file. If you are using Windows, you will find it here: C:\Users<your user name>

#7

@dang , I may not completely understand your situation but when you asked if you were missing obvious I was wondering if you were entering the length of chain that you wanted it to come out in the place for that variable…?
It may start with 10 MM or something but you can change it. Maybe I’m not reading correctly.

1 Like
#8

you are replying to the wrong person

#9
  1. MakerMade kit - new this Month with 5’ x 10’ frame - “wall” type - no mods
  2. Firmware v1.26

    “5. Try the chain extend again” - do you mean from it’s current position (about 5’ out) or do I need to backtrack to the measure between motors step?
    Thanks
#10

Not automatically. You have to press the “move to center” button which is what he needs to do.

#11

Actually, don’t extend the chain any further. What happens when you press the button, on the extend page, that says “move to center”? If you are on the main screen of ground control you can also press the home button.

I’m confused by what you said earlier…

If you press “extend” once it should give you 1651mm (5.4’) and then you can just press “move to center” before attempting to connect the sled. If you had to press extend several times to get it out about 5’, something else is wrong.

#12

Update:
I unplugged and restarted as suggested.
Ran through the celebration from the top.
The left chain extended 6’+ and the right extended just under 5’.
I was able to attach the sled but when I clicked “move to center” the left motor just hummed for 2 seconds and did not move.
Where it is in the pic I assume is not center
What should I do now?

1 Like
#13

Nice build. This isn’t supposed to happen and it is frustrating. Please

#14

groundcontrol_dang.txt (1.5 KB)

1 Like
#15

The first thing that stands out is that your x and y “home” position are set at -200 and 200 respectively but should be 0 and 0. This just confirms what your picture shows, however, the question is why and how did those values get set to that (I’m assuming you didn’t do it, right? :slight_smile: )? The answer to that is over my head. I would post this in the software channel and see if anyone has an explanation for how those numbers might have been set that way.

This may get you going but I’m not sure; change those number back to 0 in GC. Click settings>advanced settings and set “Home Position X Coordinate” and “Home Position Y Coordinate” to zero. I wouldn’t bet that you don’t run into other errors since issues are starting to come up with the newer fw versions from new users (I say “from new users” only because it seems most of the active members stick with the fw that works for them).

One additional question: were you using the How To: Get Calibrated wiki or just going through the calibration steps? I found that wiki to be extremely helpful and clarified several things for me.

Looking forward to hearing the outcome of resetting x and y home position.

Edit: After changing the settings back to zero, press the home button on the main screen and the sled should move to the center.

#16

So I was able to get back on this this weekend.
The resetting of X & Y to zero didn’t seem to work. The sled didn’t move to 0,0.
I fiddled with it for a while more and decided to clear wipe the settings, remove all the software and start with fresh downloads.
That did the trick! Everything went perfectly and I’m happy to report that I was able to cut my first test shape with ease.
Thanks for the support.

5 Likes
#17

I have not bought a kit yet due to space restraints but am glad to know that so many people are willing to jump in and help! @dang please be sure to post a pic of your first cut. curious to see how it goes. Great progress!