Chains extended in calibation do not reach the sled

Sorry, sure it’s somewhere in the forum but I don’t have the nerve to search at this stage and from the workshop.
I’ve extended both chains but they are to short to connect the sled. Can I just click extend again for both?
Bottom feed

The chains get extended by a fixed amount that’s listed in settings. I had to increase the value to accommodate my 12-foot beam. I don’t recall the value I used though.

It’s Settings->Advanced Settings->Extend Chain Distance

The default is 1650. I might have used 1800.

I was hoping not to go back to square one, thanks for the fast reply. I mounted both chains together to reach the motor distance and unmounted them again. We seriously need a user input field for the extend chain on that screen or a +100 button, going with wider top beams. I usually don’t drink before 5pm but today 4:19 seems reasonable. I will do a new attempt tomorrow with your valuable input. What happens if I click move to centre?
I might be able to mount the sled then :thinking:

Well they extend but still I would need to mount the sled somewhere over my head. Not even close to the centre. Giving up for today :frowning:

1 Like

Yeah, I feel for you. I ran into the same issue and had to back out of calibration and restart it. In my opinion, we should just have the code calculate how much chain to extend based upon distance between motors and the yoffset. Just takes someone to figure out the code though it seems simple.

GroundControl doesn’t issue a command to move 1650 mm… it issues a special command to reset the chain lengths and when the firmware receives that command, it looks up the original chain length (from settings) and issues a singleaxismove for each motor equal to that length. So, the during calibration, when the motor distance and yoffset are entered, a distance needs be calculated (I think it should be calculated to be about a foot below center to give slack) and then GroundControl’s chainExtendLength setting needs to be updated thereby causing the controller firmware’s originalChainLength to be updated (we apparently struggle with using the same names for variables).


A +100 button would not be to difficult from a 20 years back programmers perspective and it’s missing from the opinion of someone that has feeling wise close to 100 calibrations. Move to centre did extract the chains but sill not enough (far to high on the sheet). Clicking extend again retracted the chains and that does not make sense at all. Need to digest it first, replicate it second and then write a divesting review or not.

Is the groundcontrol.ini updated on the fly after each step or in intervals completing several steps?

You are correct, it would not too difficult. I’d rather see if automatically calculate the proper amount so you don’t have to go back and click to extend more chain.

As for:

This actually makes sense because all that extend chain does is tell the controller to make each chain length equal to 1650 mm (or whatever value you have in settings). So if you had gotten extra chain to come out by pressing “move to center”, it will retract it when you press “extend”.

1 Like

Move to center was added to fix this issue, but the fact that it didn’t extend enough means that something is up. That the chains retracted when pressing the extend again makes sense because that command will move them to the target length from wherever they currently.

I think the first step is to figure out why the move to center didn’t move to center. Do the measurements for the rotation radius and distance between the motors seem reasonable?

1 Like

I think @gero is using a 12 foot frame so the 1650 mm distance isn’t enough to allow him to attach the sled (I had the same problem and upped the 1650 mm setting to 1800 mm … i think).


you really want this distance to be an integer multiple of your linksize (1650
is not, 1651 is, so when you do this, your chain length is off by 1mm before you
start, which is not a good start for accuracy)

you want this to be a length so that you have a sprocket tooth at 12 o-clock

David Lang

Hmm… I had to extend the distance setting in GC to get the chains long enough for my 12’ bar… went to 2000, which definitely leaves the cogs at a non-12 o’clock position. Something to change in the next go-around.

This is what started my night long dive into a searching for a bug. Nevertheless, 2032 is the magic number you need @dustcloud.


Thanks! I just made the change.

I had similar issues, I think I have overcome it, move to centre, had the sled out by about 30mm to the left and about an 1" low. My thought was if the machine thinks its on centre, what if I just move the chain links till it is pretty close. That seems to have worked. and it seems to be running accurately. I will be running my first accuracy test today and I’l report. My thought was, is it possible to add a “set centre position” button like the Home button. Then we can just manually drive the slid to centre and save it.

Where does the sled go if you use the Actions/ReturnToCenter button? When it arrives there, the X and Y position numbers should both read 0.00 and the sled be on the middle of the workarea…

On my first attempt, I tried to manually move it to the centre and save it, Don’t know what I did, but it was totally wrong and Return to centre saw the sled just about fall off the bottom. Next attempt had some other issues, but I think I have it right now, I’ll check it when I get back to the machine.

1 Like