I'm stuck! Maslow stop in the meddle of the cut

Hi All,
I’m cutting a Podium sign for an Event 2 weeks from tomorrow.
For some reason one of the letters does NOT want to be cut!!
I split the Gcode several times, cut everything but the " E " letter, stops at line 50.
I’m cutting 1/4" MDF with 1mm cutting bit at 1mm pass at 200mm p/min.
I start the cut with Ground Control V.1.20 and thought would be a GC issue then I upgrade to V1.23…
Can someone look at the Gcode and help me out? I have absolutely no idea what is going on!!

ULTA CNC E.nc (36.7 KB)

also here is the full Gcode that stoped at line 3571.
ULTA CNC1.nc (357.1 KB)

Thank you in advance!!

Thanks for tracking it down to the line and supplying a shortened file that exhibits the issue - it helps to narrow things down. Both files look reasonable in g-code simulator.
I’ve run the “E” file here with GC and a simulator version of the firmware and it ran to completion, no stops or odd behavior, but let’s keep digging.
Can you describe “stops” in a different way? does GC remain open? If so, does the lterminal output on the right side of the screen say anything out of the ordinary? A screen shot of that terminal output during the “stop” might have clues. A copy (.zip it…) of log.txt might also help.

And here is the SVG file.


Thank you !

I think the forum software requires SVG files to be .zipped

GC stay open, nothing on the terminal.
I will run again and copy the log file

Thanks for looking at it

1 Like

ops!! I didn’t know that
I will zip it, if you would like to look at it.

BTW I’m using a Mac book pro…

1 Like

I’m interested in the right side of the GC screen during the “stop”.
Here’s mine shortly after line 50 ran (sorry for the large picture, you’ll need to click on it to see the whole thing):

Can you do a screen shot of the problem?

here it is.

Yes very similar, Z-axis is gray out…

That means that GC thinks your Z axis needs to be manually adjusted.

At the time you took the screen shot, is GC just sitting there, waiting for something? If you stay hands-off, does it ever move again?

If you’re comfortable in the Terminal app, you could copy the log.txt file from in the folder to your home folder by typing

cp /Applications/groundcontrol.app/Contents/Resources/yourapp/log.txt ~/log.txt

It might be large and need to be zipped, maybe it will have a clue.

Yes, I can do it! Just give me a second, I’m doing something on my mac… that could coise the problem…

1 Like

can I delete the log file and create a new one? with just this cut?
the file is like 900 pages long

Yes, that’s a good plan. You can even delete it while GC is running, just before you start running the cut file.

yes it just sit there…

and here is the Log File.
log.txt.zip (85.4 KB)

SVG zip ULTA CNC1.svg.zip (6.4 KB)

There is a setting at the bottom of the Settings page, ‘Buffer Gcode’ Is that set ‘OFF’? If not, could you try turning it off, then quit GC and start again, and try the “E” file.

1 Like

it was on! Lets try

1 Like

Looks like it is going!!!

Thank you so much!!!
I really appreciate

1 Like

Yeah, turning that on makes the simulator pause at that point as well. I think you found a bug!