Maslow Home Maslow Community Garden Newsletter

Designed at 0.0 opens bottom left GC

#1

With a fresh calibration performed and the sled sitting at 0.0, I set up a new file in MakerCam:


It’s clearly centered at 0.0
When I open it (or any other file- even one I previously successfully used) GC (v1.26) places off the work area.

If I clear the G-code and open it again, the line indicating the travel to the start point is oddly off.
This was happening after I attempted to cut my second shape so I tried to reset GC (failed) but I went ahead with a chain calibration (success) but there’s defiantly something afoul with GC.
Does anyone know what is happening or why GC will not reset?

1 Like

#2

When I used to be able to get on GC oftentimes the line to the first plunge or cut would be in the wrong place. I would have to clear the G-Code and retrieve the file again. Or maybe I’d just shut down and relaunch GC until it looked right. :man_shrugging:

0 Likes

#3

I’ve tried that.
I went as far as to re-calibrate.

0 Likes

#4

I identified how to delete the GC settings.
I’ve also flashed the firmware again.
Since then I’ve been getting these warning messages.
Chain length and z axis adjustments?
It will not calibrate properly.
Something is defiantly screwy!

0 Likes

#5

Sorry that you deleted the settings. I guess the initial issue with the part beeing off the sheet could have been solved by moving the sled to the centre and clicking ‘Define Home’.
The Z message you see now is because by default GC assumes no z-motor installed. Change it in the settings.

The chain warning is due to that one or more machine parameters are not correct. You need to calibrate again. Or, do you still have the groundcontrol.ini from before you wiped and flashed?

2 Likes

#6

I’ve been calibrating and calibrating some more.
The only luck I’ve had is ‘Wipe EEPROM’ and starting fresh.
When I deleted the GC backup file on my win7 pc, it made the .nc file open in the correct 0.0 position. But the chain length error wouldn’t let me go any further.
Then the Z axis thing popped up which confused me further because I had just gone through all the calibration steps, including setting the Z and the test pattern without any issues. I then went through the process again and nothing was fixed.
Now I’m at trying to ‘Wipe EEPROM’ and it fails.
Is there an alternate way to flash the brain for a clean start?

1 Like

#7

So, I worked pretty herd to find the root cause of this issue. It is one of a few things. Check the Advanced Settings Chain Length. Set it to some different number, and then back to the original. If that doesn’t work, do the same for Distance Between Motors, Motor Y Offset, Chain Sag Correction Factor, Chain Tolerances.

Also, Chain Elasticity should be changed in format to something that is not scientific notation. So, 0.0000081 rather than 8.1e-6. I don’t know if this is actually effective in your version of G. C.

0 Likes

#8

That’s interesting information.
What ended up working was to reset GC to default settings.
I made sure the Z was toggled on before calibrating again.
This time everything went smoothly enough to be able to cut a full shape!
It’s unclear how things get so out of wack as I haven’t changed any settings manually.
Tomorrow I will attempt another shape and hope for the best.
If the bugs come back I will try your trick.
Thanks for the effort!

1 Like