Maslow Home Maslow Community Garden Newsletter

Cant get calibrated


#1

trying to get new machine calibrated. I got 14 hrs in this so far. I use latest ground control update with 6 hole calibration and latest firm.

the calibration just would not go. the chains would not measure riight. gc kept crashing. i unplugged, wiped eprom set to default ove r and over again.

I got a hole 6 cal cut. skipped ritght to place to load 12 measurements. then immediately get sled error. I try to reset and hit home and sled has gone to very top, btw, and errors. Now I hit down arrow to move sled down and it goes UP.

I have increase pos error to 20 no good to 2000 and no good. I m ready to shoot this thing. PLeaase advise

just adjusted chains agin. on move to center sled goes ovre top of board I have to stop it


#2

I think I had the same error when I entered the new number for distance between motors. I did move the sled to center. I went through the process again and it worked… Not sure where it went wrong since it didn’t mess up on me again. I know this isn’t helpful and doesn’t solve your problem but I’ve had the same issue and frustration… Keep at it.


#3

I guess from another post that you are using “the holy calibration”?
Don’t get me wrong please, but spreading the information required to help over more then one post, will take longer or even bring people to opt out.


#4

I am trying to look to see if there is anything in Holey Calibration that would be causing this issue.

Comparing against the Triangular Calibration, I can see one difference between the last G-Code commands in the cut step.
In Holey Calibration, the last commands are:
data.gcode_queue.put(“G0 X0 Y0”)
data.gcode_queue.put(“M5”)

In the Triangular Calibration, the last commands are:
self.data.gcode_queue.put("G21 ")
self.data.gcode_queue.put("G90 ")
self.data.gcode_queue.put("G40 ")
self.data.gcode_queue.put("G0 X0 Y0 ")

In Holey Calibration, the last command is a “M5” command. I believe this is ignored by the Firmware, but I haven’t looked to see.

This sounds like a motor/connection issue. Have you gone through the “Actions=>Test Motors/Encoders” step?

This may be something outside of GC. What operating system are you running? What version of Python do you have installed? How are you starting GC? If you are running in a terminal, there may be some printed text which can point you to what is going wrong.

This almost sounds like it is coming from an earlier version of GUI development. When I was developing the code, I had commented several steps so I wouldn’t have to click through them every time. If you look at the file, CalibrationWidgets/calibrationFrameWidget.py, lines 99 through 112 should not have a “#” at the beginning of the line. If they do, then that is why you’re skipping steps.


#5

ubuntu 16.4
newest ground control firm and gc. gc has holey process.

motor are all fine

i have rebooted restarted, etc. I hate to wipe eeprom cause I lose my hole measurements.

Most bizarre thing, after setting chains as error tells me. I set chains and hit go to center and I have to stop sled cause it is going off top of board.

then when clearing error i try ot move sled down and sled goes up. crazy. I m not new here, i ran a maslow 8 hrs everty day for several months.

I need the accuracy of holey. Yet I guess I can go back a version to 1.24? andjust do basic. JR


#6

PArdon me, I skipped cause i had no success with step by step calibration. Paricularly measure chains, I i finally did get chains to pull tite and gave me 300mm


#7

i just got new chains. they look like old length. could makermade have sent 12 stead of 11?
ok, right now sled is top of board offset lft about 9 inches. this is position after setting chains and hitting move to center .actually it is not move to center position cause I had to stop it.

grouind control position, rred circle, is in center of board.

what would you felas do?


#8

The length of the chains shouldn’t matter, as long as they are long enough for your sled to reach all areas of your stock, any extra just wont be used. I guess if they were super long, it might cause problems with getting enough tension, but a foot extra shouldn’t have any problems.


#9

thx,

at it again this morn. I set all to default. set chains again. and then hit return to centre. sled error came up on hitting return. I am looking at x y data in gc.
x reads 0
y reads 293.3

ofcourse sled is in center, jr


#10

there is a second thread, Park, with similar issue. I read Gero suggestions. here is what i did:
renamed groundcontrol ini.
wiped eeprom
unplugged everything, including motors
re plugged
opened gc,
hit move to center and it moved.
next tried to move sled with arrows
first error is notification to adjust z to ,5
then got sled is not keeping up
got another notification to adjust z to .20
sled not keeping up error
sled not right chain lenghts.

I set up other pc with clean firm and gc and get same errors.

couild arduino be bad?
JR


#11
  • does the ‘Test Motors/Encoders’ pass all 3 motors?
  • did you check that the screw for the sprocket sits on the FLAT side of the the motor-shaft and is tight?
    image
  • for sure you un- and re-plugged the cables, so i would check them with a multi-meter to find out if one cable is faulty
  • the disc for the motor encoder is glued on the shaft under the black cap. If the disc is loose that will also cause an error
    image
  • please upload your groundcontrol.ini

#12

fixed thanks alll I appreciate all help

ran chains again. this time it was valid error to set chains.

set chains, moved to center, sled is reacting to arrow moves, no error.
only additional was rename ini and unplug repllug.
thx all and I hope this sticks


#13

Probably more forum members are running their systems using the triangular calibration with the ring or parrallogram sled connection. Perhaps you should start there, get the bugs out, and then move on to the Holey method. The triangular process has a step-by-step routine in GC that is pretty straightforward, and if irregularities occur, a lot of forum members have already “been there/done that”, so you might get better feedback. I have been away from my shop for awhile, and look forward to trying the Holey method. But, a lot was learned with the triangular cal, and in the process, my machine was incrementally improved several times.

Take a deep breath and try again. Also, lock up the firearms!


#14

hey, back to getting errors. and now i can not adjust z, i get notifications a setting z one told me to lower 139mm.

what r these notifications how do I get rid of them. problem is it has jammed z so hi right to stops . the motor is going to fry.

I cannot lower z.


#15

Go to settings an turn z-axis on. It’s off by default.


#16

oh wow will apologize if this is it. geeeeez


#17

@Joshua any more thoughts on this? Why not make it the same?I had this error come up again too (EDIT4).. Maybe the home button needs pressed after every setting change?


#18

JR Update:

I believe cause of issues is this: I crossed one wire on build, the left motor and z. I corrected this right away. However I believe the arduino said to herself “if you r such a dumass to cross my wires, I will torture u 4 24 hrs.” That arduino is super bitch.
my fix thx to all

  • I wiped eeprom setting all to defaults. ( I wrote down holey specs first.)

  • I unplugged all, shut down gc.

  • Replugged all, restarted gc, changed 3 defaults, top to bottom, to triangle, and thx to Gero, turned on Z.

  • set chains manually. (i have done this at least a 100 times in last 7 months, any secret I am missing?)

  • crossed fingers and hit move to center, yes it worked. center bout 8 " low tho.

  • I added each holey spec one at a time in settings, shut gc, restarted and moved to center each time,

  • The last time i did this changing motor to motor distance blew me up. errors again. this time it went.

  • Got all holey specs in and had a gud cut day. BTW sled moved 8 inches up as I added each spec with major move on adding sled weight.

Had a good cut day, did holey again and measurements tightened up nicely, not perfect, centered sled too. I have weakness in center top of board where cuts are a half inch off. Plan is to run holey again and optimize more.
thx jr


#19

I pulled that from @madgrizzle’s original 5 point Holey Calibration test cut. I think someone more familiar with G-Code would be better positioned to answer the question about whether or not it should be there. We could try remove it, just to check.