[Solved] GC 1.11 strange results during calibration

screen -2 select bottom
screen -3 select triangulation
screen -4 enter 444.5 mm
screen -5 set gears to zero

screen -6 screen shot of left motor show chain wrapping over gear from the left side, bur when I start the routine the gear moves counter-clockwise and chain falls off. I moved chain to wrap from the right side and complete the measurement test.

screen -10 set ring to 140mm
screen -11 measures out chain, connect sled. The sled is centered vertically but not horizontally.

The Z-Axis page calibration page moves the sled motors instead of the z-Axis. When I run the Test Motors and Encoders from the Action menu the left, right and z motors all move up and down.
I tested on raspberry pi and also Ubuntu. Any idea why the sled motors move instead of the Z-axis?

I thought we still did the measurement the same way regardless of chain over top or bottom (someone correct me if I’m wrong). I know the calibration routine spools out a negative amount of chain with the bottom configuration, but I assumed that because its in a bottom configuration, it would result in basically the same as a top configuration (motor turns clockwise).

If I’m right, its as if the arduino didn’t get the message that its in a bottom configuration.

Edit: this is where I get lost in the code. It’s not obvious how the bindings are setup so that a change in a variable causes the settings to get pushed to the firmware.

Which motor moves (left or right, or both) when you use the z-axis page?

It was both motors. I’m going to re-baseline everything and start over with 1.10 GC and wiped eprom.

Thank you

1 Like

I guess the “self.config.add_callback(self.configSettingChange)” line updates the settings… assuming the callback is fired when set outside of the standard kivy settings ui.

This is very strange. I will try to replicate on 1.11 Monday morning and see what I can figure out

Perhaps to help diagnose the problem, try it again and see if the chain still falls off (i.e., left motor turns CCW). If it does, go to the settings and see if it’s set for bottom feed and triangular kinematics. If it’s not set there, then there is an issue (I think) with updating the settings… then try setting it manually and repeating the calibration.

@madgrizzle, Thanks for your insight. I have a day with family, so I will try to look at it again, this evening.

I had a similar issue when calibrating yesterday (GC 1.10). I didn’t understand the instructions when it came to “adjust chain”.

When you measure distance between motors, the left chain is already extended a known amount. So when you “adjust chain” it pulls the chain back to the correct dimension. My mistake was assuming I needed to reset the left chain to the first link. I kept taking the chain off the left and right sprocket and then resetting the first link on the left sprocket.

The right chain rotated correct and fed the correct amount. I was so frustrated when the left chain would rotate the “wrong” direction. My ignorance and inability to follow instructions are just some of the services I offer.

A small suggestion:
Maybe a few words added to the calibration page on what the expected outcome should be.


That’s a good point and I questioned that when I first was calibrating. Maybe we can clarify the language.


I did not have a chance to work on my Maslow today. But, I toggled thre the calibration steps and I guess this screen threw me off several steps before you reach the Adjust chain screen , It says to remove the chain. Seems counter intuitive to leave the chain on, as suggested, but I will try it, tomorrow.


I would also mention on the measure chain screen it shows chain wrapping on to the sprocket from the left on the left motor. When I hit measure the gear turns counterclockwise, so I re-did step with chain wrapping over from the right side of the gear.



Yeah, that sounds like a problem. I don’t think the motor should turn counterclockwise. It’s as if the controller thinks you are in a top configuration whereas GC thinks you are in a bottom configuration.

When you are in a top feed configuration, you do not reset the left chain. However, you will need to reset the chain for bottom feed configuration because the calibration routine for measuring distance between motors uses only a top feed configuration (to the best of my knowledge).

@bar said he would look at it today… I suspect a problem with updating the controller with the correct configuration.


That’s exactly what I am thinking. The picture is right that the chain should come from the left just like we always used to do it. I will run some tests today and see if I can track down what is going on


I’m not sure how you are testing, but maybe starting from a new configuration (i.e., wiped eeprom, no groundcontrol.ini file) might result in the problem rearing.


Good point! I wiped my .ini file but not the eeprom. I will give it another go with the eeprom wiped

Instructions anywhere on wiping .ini and clearing eeprom?

goundcontrol.ini is located in your home directory. I suggest renaming it rather than eliminating it. Do this while GC isn’t running. It will set all user changeable values back to default values.

Wiping the EEPROM is found in the Actions/Advanced list. After doing that, you should probably quit GC and start it again. That will set all many internal values back to default values.


[Success!] After work today, i was actually able to sit down for a few hours uninterrupted and dial everything in during calibration after wiping the eeprom and grabbing fresh tarballs of the 1.10 Firmware and GC. Loaded some Gcode and cut out a shape with my Raspberry Pi 3b without a hitch.Thanks to all for your guidance.


So the motor didn’t turn counterclockwise during this calibration?

No, everthing seemed to work as planned until i came up to the the Z-axis zeroing. Ater measuring out both the left and right chains, I hit next as instructed on this screen.

When I got to the Z-Axis calibration, and went to lower the bit, it dropped the sled down instead.


But this time I noticed the sled actually looked like it was centered. I stayed calm and hit done and quit GC. At this point it looked like I had a sane groundcontrol.ini, I restarted GC and was able to run and cut a piece test piece.

Also, I did not mention earlier, I was having some issues with running OpenGL on the RPi 3 and realized I needed to give the driver CMA (contiguous memory access) during boot up, after reading up on the Broadcom engineer Eric Anholt blog and github, he’s porting the videocore4 SOC to open source. He’s already giving talks on VC5, makes you wonder what we’ll see when raspberry 4 finally rolls out a year from now or so. :slight_smile: