Maslow Home Maslow Community Garden Newsletter

Encoders alternating failing test L and R motors

Hi All,

I’ve had a trawl of the motor test fail threads that I could find but I seem to be having an issue that I’ve not seen before in the forums. Mainly the left motor but when I wiggle the cables, sometimes the right motor is failing the encoder test. Both are failing alternately in direction 1. I’ve tried swapping the cables and the same thing is happening so I’ve ruled that out. I saw mention of trying to read directly from the arduino to see if its an issue with the interface with groundcontrol but I’m not sure how to do that. We bought the machine already setup and haven’t really changed it since buying other than to set it up again in the garage.

Any help is greatly appreciated.

Thanks

okay, update. All passes when not under load? possible gearbox issue? could it be too much resistance because of cold?

That’s good to know that everything passes when not under load. That test was really designed to be run under no load so I wouldn’t worry too much about it. Are you seeing any other issues when cutting?

Thanks @bar for the reply. We’ve seen issues lately with the Z axis. First cut is retracting and were not getting full penetration of the bit into the material. Also a couple of times the Z axis has bcked itself completely out away from the material.

Those sound to me a bit like the kind of behaviors that one would see if the signal from the encoder wasn’t making it back to the controller board reliably. I would say maybe unplug and replug the z-axis cable?

I’ve tried that with all of the cables, removed the shield and reattached. Also regularly getting a timeout on the connection, only for a few seconds and then it’s reconnecting but this will happen over and over until I plug the USB cable out and back into the PC.

Have you checked that the power supply and it’s connections are good?

Hmmm the connection timing out sounds like an issue that could be resulting in other issues and we should solve that first. Some folks have reported that using a shorter USB cable can help. That’s what I would try next.

Hi guys, thanks for all the suggestions. We’ve tried a new usb which worked for a while but now we’re seeing the same issues. It seems to be mainly the left hand motor failing only in the retract direction. Also the left motor sounds a little rough compared to the right hand motor. I’ve tried swapping the cables around, new usb with ferrites on each end to help with any signal interference. Also we get lines appearing on the screen when the motors move, looks like signal interference. We managed to cut one sheet perfectly the other day but now we’re back to having these issues. Not had the connection time out again though… Any more thoughts?

Cheers

Let’s try to isolate what else could be plugged into the same the same outlet because that’s another common source of interference. Maybe try with the maslow plugged into one outlet and the computer plugged into a different one with nothing else running in the room. I know I have one power drill which if I uses it in the same room causes the USB connection to drop.

Currently the Maslow, the pc is on one, the vac/router is on a second and the power for the maslow motor board is plugged into a third outlet. They are probably all on the same circuit though, I don’t know what else we could do about that. I’ve read that the shop vac we’re using creates a lot of electrical noise.

Got it, so it sounds like you’ve already been pretty proactive about taking care of things there.

Hmmmm is trying without the vacuum an option?

I was about to try this and we realised that the vaccum doesn’t run when doing the encoder test so I’m not sure that it would be that. I will try it this evening but do you have any other suggestions? I’m running out of things to try. Cheers

Do you have any options to try a different computer? If not it might be an option to run WebControl on a raspberry pi to keep the USB connection really short.

It would really help if we could isolate when the issue happens and when it doesn’t.

This might sound stupid, but have you tried unplugging all the connectors and blowing on them and putting them back in really firmly?

I was wondering if using another device would be something to try. I do have a raspberry pi first or second gen which we could use. I’ll have a look into that.

It’s not a stupid suggestion but I have checked all the connections. I was thinking about buying some contact cleaner and going through it. Also it’s kept in a slightly damp garage so that may have affected some hardware components.

1 Like

Let’s give that raspberry pi a shot or some other device. I remember Hannah’s computer was much less reliable for connecting than mine so there is some device to device variation.

Okay, looks like the encoders are passing the test reliably using my laptop, makes sense. The desktop we were using must be ten or more years old. The issue now is that I don’t know how to use we control… Also now having an issue with the Z axis. Once calibrated to 0 and homing the sled, the Z axis extends around 10mm into the work piece and only records a move of 5mm. Also in the chain calibration it’ll only extend the chain by 1651mm but our motor spacing is set as 3564mm in the Maslow settings so the chain won’t extend to reach. I appreciate the help you’re giving us. Going to give up for the evening and read up on web control.

I’m not in a position to check, is there a good way to connect everything to an earth ground? Iirc the plug in supply is only two wire, no separate earth ground, as are most laptops.

Phenomenal! Nice work :grinning:

This one I feel good about. Different kits use different pitches for the z-axis threaded rod. There is a setting. If you are getting double the distance just change that number by 1/2.

Which step in the calibration process is this? The part where the chains extend from both sides?