Maslow Home Maslow Community Garden Newsletter

Motor fail test but still move

When I run a motor test I get a fail on each motor, but the motors do turn (verifies in the chain length setup screen). At least the left and right motor, I couldn’t get the z axis to move. When I tried to move the z axis it sounded like it was adjust the left or right motor instead. I’ve checked connection, power, usb, restarted PC, etc. Any ideas what to check next?

  1. Open Arduino IDE serial monitor.
  2. Connect Maslow board and motors with encoders.
  3. Make sure u get any readout on serial.
  4. Turn encoders by fingers

This way You will get information: Is my left encoder reading left motor signal in right direction?

Then You can modify maslow Arduino component Setup.cpp and hardcode your motor direction (pinout) setup.

When I go into the chain length setup screen the motors will move the correct direction (CW or CCW).

How can I turn the encoders by hand? The motors are quite rigid.

ahh, Open encoder case, then you will see black magnet disc. Hall sensors read magnet poles and send signal to Maslow board. That data is transferred to your computer via serial communication.

You can read that data via arduino serial monitor. That way you can determine that You get any signal from encoders. It will tell you:

  1. Is my encoder connected?
  2. Is my encoder working in right direction?
  3. Is my encoder loosing connection?
  4. Am I getting same amout of pulses rotating back and forward?
  5. Are my motors In1 --> In6 connected right?

Motor test, tests: Are my encoders give signal in direction ordered by maslow board? Are they move equal amount of pulses?

1 Like

@MarcinanBarbarzynca is right that the issue is probably with the encoders…but having all three fail at the same time seems like a bit much. Basically what the test is doing is driving the motors and then verifying that the motors are moving by watching the values from the encoders. If you are seeing the motors move, then the issue is with reading the encoders.

Are you sure that all the cables are securely plugged in? A loose connector could be causing the behavior you are seeing.

The motor connections are definitely secure, and they do move when I use the chain length setup screen, so I know they are connected. I will test the encoders as described and see what I get.

1 Like

Is this using the stock motors and wiring from one of the kits or is this a scratch build?

It is a kit from Maker Made.
I did modify it slightly, as I combined two Maker Made motor cables fo make a longer motor cable for the left motor, but it meggered out fine. Good connections and no shorts.

if you managed to reverse any of the connections, groundcontrol is not smart
enough to notice that the motor is turning the wrong direction.

there are B codes that will run the motor and output the positions, I would have
to look them up in the source code, but they could tell you if it looks like
it’s running in the wrong direction.

David Lang

I had to solder wires directly to motors because i had faulty connectors.
Rly. You really need to see that arduino serial monitor. Open motor case, rotate magnet and watch your monitor. Do You get good readout?
You can determine that way if your connection between motors and maslow shield is good and you don’t flip flop motor DC poles.

The worst scenario will be when you bought bad cnc shield.

I haven’t had a chance yet to test the encoders, but I did finish calibration and make a few cuts, and all works well. But the motor test still fails on all motors. I am guessing it’s just a bug in the software?

Mirrored cuts :?
Just lols becouse it should work on Z axis too.

All cuts seem good. I cut this yesterday, and still the motor test fails. I don’t feel worried about it any more. image

2 Likes